Check engine light on after Uconnect upgrade - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > LD RAM - Ram 1500 Forum > 2018 Dodge Ram Forum


2018 Dodge Ram Forum For specific discussion of the 2018 Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 06-14-2019, 08:30 PM
30West 30West is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2017
Location: Texas
Posts: 6
Gender: Male
Vehicle: 2017 Laramie
Trim Level: Laramie
Color: Blue
Engine: 2014-20?? 392ci (6.4L) Hemi V8 410hp 429lb/ft
Rep Power: 0
Rep:10
30West is on a distinguished road
Default Check engine light on after Uconnect upgrade

Hey all,

Just finished installing a Uconnect 8.4 upgraded from 5.0. Ordered it from Infotainment. When I started the truck to check the new system I noticed my check engine light was on. I took a quick spin around the block to see if it would go out but it stayed on. Everything else seems to be in good order.
Anyone have any experience with this?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-15-2019, 07:59 PM
NevadaMike's Avatar
NevadaMike NevadaMike is offline
Dodge Ram Forum Senior Member
 
Join Date: Dec 2014
Location: Bunker in undisclosed location
Posts: 3,408
Gender: Male
Vehicle: 2014 Dodge Ram
Trim Level: Tradesman
Color: Black as your heart
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 6
Rep:174
NevadaMike has a spectacular aura aboutNevadaMike has a spectacular aura about
Default

Have you checked to see what the code is thats causing the light to come on? A auto parts store should be able to scan it for you if you can't do it yourself.
__________________
[SIGPIC][/SIGPIC] I know the voices in my head aren’t real, but man, do they ever come up with some great ideas.
Reply With Quote
  #3  
Old 06-16-2019, 02:32 PM
30West 30West is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2017
Location: Texas
Posts: 6
Gender: Male
Vehicle: 2017 Laramie
Trim Level: Laramie
Color: Blue
Engine: 2014-20?? 392ci (6.4L) Hemi V8 410hp 429lb/ft
Rep Power: 0
Rep:10
30West is on a distinguished road
Default

That was my next stop. The best way seems to post it on a forum, because as soon as I did, the light went out..
Reply With Quote
 
  #4  
Old 06-16-2019, 09:40 PM
9thousandfeet's Avatar
9thousandfeet 9thousandfeet is offline
Dodge Ram Forum Senior Member
 
Join Date: Oct 2017
Location: Rocky Mountains
Posts: 531
Gender: Male
Vehicle: 2018 Dodge Ram 3500, SRW
Trim Level: Tradesman. Crew Cab
Color: Granite Crystal
Engine: 2014-20?? 392ci (6.4L) Hemi V8 410hp 429lb/ft
Rep Power: 2
Rep:122
9thousandfeet will become famous soon enough9thousandfeet will become famous soon enough
Default

There will likely still be a stored code that could be retrieved in case you're curious about what triggered the CEL in the first place. I think I would be.
Reply With Quote
  #5  
Old 06-16-2019, 11:29 PM
bad440's Avatar
bad440 bad440 is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2016
Location: Fonthill, ontario
Posts: 8
Gender: Male
Vehicle: 2010 R/T Challenger, 2016 Ram
Trim Level: ST
Color: Red Pearl
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
bad440 is on a distinguished road
Default

I installed the 8.4 infotainment system in my 2016 Ram 2 months ago, no problem at all; don't think it has anything to do with check engine.
Reply With Quote
  #6  
Old 06-16-2019, 11:53 PM
GTyankee's Avatar
GTyankee GTyankee is online now
Dodge Ram Forum Senior Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 32,520
Gender: Male
Vehicle: 2016 Ram Ecodiesel 2 whl drive
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 32
Rep:3060
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

Many times when something is installed, it just takes a few driving cycles for the computer to adjust & accept the new part

Like when you replace a smog emissions part, the vehicles almost instantly runs better, but it won't pass the I/M checks until after a few driving cycles
__________________
2016 Ram 3.0 diesel 3.55 w/LSD, G2 tonneau, Line-X, Weathertech mats, Mag-Hytec differential cover, Nfab bars, CB radio, EGR bug deflector
Reply With Quote
  #7  
Old 06-22-2019, 12:44 AM
ettodd ettodd is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2015
Location: huntsville al
Age: 46
Posts: 12
Gender: Male
Vehicle: 2015 ram 1500 bighorn
Trim Level: big horn
Color: flame red
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
ettodd is on a distinguished road
Default

you probably turned the ignition switch on to check the radio and still had the shifter unplugged.it sets a service shifter code that goes away after several key cycles.several people had it happen including me
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 03:13 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors