New iboards. Wrong hardware? - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > LD RAM - Ram 1500 Forum > 2014 Dodge Ram Forum


2014 Dodge Ram Forum For specific discussion of the 2014 Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 07-10-2019, 09:38 PM
nkaiser81's Avatar
nkaiser81 nkaiser81 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2019
Posts: 7
Rep Power: 0
Rep:10
nkaiser81 is on a distinguished road
Default New iboards. Wrong hardware?

Bought 5" w2w iboards for my 14 crew off Amazon. Opened. 2 problems. In the box rails where there should be open hex holes. There are factory tacked nuts on the inside. Other problem. Unsure. But pictures online show J brackets. I recieved L bracket. Wouldn't necessarily complain. I think the L looks cleaner but seems like it is missing support. But I think the J has the support to the pinch weld. Looking for feedback as to what others have experienced. Thanks
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 03:33 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors