DODGE RAM FORUM banner

backfire

  1. No start after lifter replacement. Bent pushrods help!!!!!! 2004 5.7

    5.7L V8 Specific Topics
    Hello there this is my 1st post on this forum excited to get some answers or suggestions. My cylinder 4 intake lifter failed but it didn’t ruin the camshaft bc the Pushrod fell out of rocker So I replaced all 8 lifters on passenger side. So I repaired and reassembled it, and when I crank the...
  2. No Start

    Electrical
    Truck started to act up two days ago. went outside started her up and let it warm up for about 15 minutes ran just fine.started driving got about 3 miles down the road and she started to miss and backfire almost stalled. i kicked it into neutral and got it to clear up.started to go up the next...
  3. 2006 RAM 1500 4.7L Long Backfire Issues

    4.7L PowerTech V8 Specific Topics
    Ok, I'm having an issue with my 4.7L and a long backfire when I'm driving. Its not very pronounced when on the throttle, but when I release the pedal fully it backfires long and rapidly. It does not make this sound in Park when given throttle. I just bought this truck used about 3 months ago...
  4. 99 2500 backfiring through intake occasionally

    V10 Specific Topics
    Hey guys. Heres the situation. Truck has irregular backfiring that can be heard from exhaust and intake. First 1/4 of accelerator pedal travel is when its noticed. Past that first bit, the truck will take off with more than enough power to scoot on down the road and no backfiring what so ever...
  5. My 4.7L spiders then blows blue or gray smoke wtf?

    2009 Dodge Ram Forum
    Please help if any of you out there have the same problem ...senario.. Cruising down hwy cruise control set at 75 stop for fuel and at the off ramp stop sign making a left attempt to accelerate with my lead foot normal throttle stomp then ..... Have you ever seen Beverly Hill's cop ? Eddy puts...
  6. Temp gauge, maybe more?

    3.7L Slant 6 Specific Topics
    I have an '86 W100. I replaced the coolant temp sensor because the temp gauge was not working. Now it works, but only when the key is in the start position. It also has a searching idle, sometimes high, sometimes low, and backfires frequently when cold. All of this makes me think that the...
  7. 99 3.9L intermittent problem on hot start only

    V6 Specific Topics
    I have a 99 3.9L, always runs great when starting cold ( morning, after sitting a couple hours, etc). If shut off and restarted within an hour or 2, about 1 time in 4, she will have NO acceleration, top speed of 3 to 5 miles per hour even with the "foot to the floor" and heavy backfire. NO...
Top