DODGE RAM FORUM banner
map sensor
1-5 of 5 Results
  1. Powertrain
    Hey everyone, I have an ongoing issue with my ‘13 6.7 Cummins. A few weeks ago I was pulling a trailer, nothing too heavy, but I was using my exhaust brake because I was on a winding backroad. about 15 miles from home my check engine light came on. When I got home I checked the code and it gave...
  2. 5.7L (345 cu in) HEMI V8 Specific Topics
    Howdy. I’m doing a cam/lifter swap (bad MDS lifter) on my Son’s 15’ RAM 1500 5.7 and hit a roadblock with the MAP sensor connector. I can see that there’s a lock tab, but I can’t get a good enough view to see how it unlocks. Granted I was working in the dark with a shop light, but that sucker...
  3. 2009 Dodge Ram Forum
    I'm new to the forums so bare with me lol.Recently I bought my 2009. Drove it fine with no issues. Then all of a sudden I get bored P0300, P0302, and P0306 eventually. I've replaced all 16 plugs. 2 injectors and still I can feel a "shake" when idling. No codes sense doing all this. I've been...
  4. 5.9L V8 Specific Topics
    1996 dodge ram 5.9 When truck is running in park it sets surges really bad and it smokes from burning to much gas. When climbing hills or accelerating it stalls out and sometimes die. Computer says map sensor is bad but ive put 2 new ones on it and still says its bad. Wont run with new one...
  5. Cummins Diesel Specific Topics
    Hi, I have a Dodge 2001 Ram 2500 with a diesel engine. Resently, while traveling down a very rough road, I started to get an engine miss. I checked the codes and the problem was the MAP sensor. The wiring plug had come loose. I put it back on properly and the miss disapeared. How ever, I...
1-5 of 5 Results
Top