DODGE RAM FORUM banner

rough running

  1. Running Rough at 1,500 RPMs

    2010 Dodge Ram Forum
    I just purchased my 2010 Ram 1500 Big Horn, and love it. Having one problem with the engine though that I'd appreciate insight on. The engine runs rough when it's under light acceleration, and is especially rough around 1,500 rpms. At higher RPMs or under fuller throttle it runs smooth as can...
  2. CYLINDER 2 MISFIRE nightmare

    3.7L PowerTech V6 Specific Topics
    So I have a 2008 dodge Dakota with the 3.7. its throwing the p302 code for cylinder 2.maybe 1,000 miles ago it was throwing a random misfire code so i did plugs and coil packs and it fixed the problem but now throwing misfire for #2. i moved the coil around and the problem stayed at #2. i...
  3. 2000 Ram 1500 Rough-Running Issues

    5.9L V8 Specific Topics
    So, I have a 2000 Ram 1500 with the 5.9L V8 Magnum. When I bought the truck, it had a cylinder misfire, which was eventually diagnosed to be bad valves. The engine was completely torn down, and inspected when the heads were done, and everything, including the timing chain, crankshaft seals, and...
  4. 2003 Dodge Ram with All of the Codes

    5.7L V8 Specific Topics
    Hello everyone, New to the forum and this will be my first post so hopefully I can make it a good one. I have a 2003 Dodge Ram 1500 with a 5.7l hemi. The truck has been suffering from intermittent issues for the better part of the last 6 months. The issues come and go. Some times day to day and...
  5. Fuel issue, tuck goes 10mph....

    5.2L V8 Specific Topics
    Fuel issue, truck goes 10mph.... I am at a loss and would love some ideas! My truck ran great until earlier this year when she started having serious issues. After filling the tank and pulling out of the gas station she lost all power, started coughing, sputtering and shut off. We managed to...
  6. Sucking sound after running

    5.9L V8 Specific Topics
    I am in need of some advice. My truck runs rough and is sucking massive amount of air through the IAC. It always starts and idles fine but after a few minutes it starts to run rough and sounds like there is a major vacuum leak, which goes away after another minute or two. I have changed the IAC...
Top