DODGE RAM FORUM banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys first post. have a 03 4.7l that has 250000 on it has been great truck. However about the last 6 months has been using oil no leakage. also using water no leakage. the oil cap has mustard color oil( water mix with oil) this is just on the cap not in the oil( oil stays clean). also when truck is warm light amount of water vapor comes out of tail pipe.

Now my sisters ford had the same promblem hers was a bad composite intake(not the composite part but the aluminum water pipe that connects both sides of engine) it corroded causing water to get into the cylinder.
Does my dodge have the same or similar setup? Hoping not the head. If it is; is it propbly the gasget or a cracked head.

have not pulled any spark plugs yet to see if one or two are clean (water in cylinder)
 

·
Registered
Joined
·
565 Posts
Agreed with all above. I know you are trying to think of cheap easy problems, but there are none for this. The 4.7 is known for head gasket problems, and to rack up 250k on one without having any problems previously I consider a good run.
 

·
Registered
Joined
·
565 Posts
I bought my truck used at 110,000 miles. I havent had any trouble with it to date at 165,000 miles, but I have reason to suspect that my head gasket had already went and was repaired before I bought the truck.

The radiator was new when I bought it, but had a leak at one of the end caps. It ended up plugging up with oil/ water emulsification less then a year later and I became concerned. While changing the radiator and thermostat I also saw a buildup of the chocolate milkshake in the thermostat housing. I put everything back together and bought a test when I got off of work a few days later. The test done several times didn't show any combustion gas in the coolant. I flushed the system and refilled and a few months later flushed again and didn't see anymore of the buildup anywhere. Also the truck had new plugs in it. I kept an eye on it for a while and all seems to be well.
The only thing I can conclude from that is that the gasket had already been repaired prior to the PO selling or trading the truck, unless he mistakenly dumped a quart of oil in the radiator lol.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
thank you all.
Yes it has been a good run. I'm the original owner and hardly had any problems.
Only things I had to do is change the front breaks and disk over and over, and 2 water pumps and 1 fuel pump.
Knock on wood.
 
1 - 8 of 8 Posts
Top