DODGE RAM FORUM banner
21 - 26 of 26 Posts

·
Registered
Joined
·
34 Posts
I am getting a very similar problem. A random RPM stumble, that usually only presents itself while stopped or at very slow speeds. I never have any symptoms during normal driving...sometimes it will stall out though at a stop light or bounce from 800-2000 RPM.

It is very random, sometimes doesn't happen at all during an entire driving session. When it does happen, it doesn't matter whether the engine has warmed up or I just started up the engine, it usually doesn't last very long...maybe 20-30 seconds. The headlights and console lights dim & brighten with the idle bouncing back and forth. Also I get no codes thrown...completely stock engine 66k miles. No leaks

Any idea what my problem could be? Just ran a whole bottle of Seafoam in the fuel tank, and it didn't help.
 

·
Registered
Joined
·
13 Posts
I've read through your post as I was experiencing a rumble at idle as you described. Extremely low idle almost to the point of stalling while at stop signs, changing gears, accelerating at low speeds, etc... It has been happening since I bought the truck 26k ago. Recently everything started to get alot more rough and my check engine light came on. Misfire detected in cylinders 5 and 8.


I attributed this to my old plugs which we recently played with or possible fouled injectors.


After several calls to some of my trusted parts suppliers, I was onto a lead.


I had mentioned the issues that were arising to all 3 suppliers and got the same questions.


What's the mileage?
a) 326,000km


Have you checked your fuel pump/internal filters?
a) no


Sure enough. Dropped the tank, pulled the pump and the intake sock was jammed, the regulator/filter on top barely forced gas through the lines. My part suppliers were correct. My engine was running lean and I could have easily burned up a cylinder or the whole engine.


New plugs for good measure. Good cleaning to the fuel injectors and a brand new fuel pump including intake sock and regulator/internal filter.


Tada! Idles down to 550 in neutral/park/drive when stopped and no stumble. Can not even feel the truck running. No issues with acceleration either.

I notice you said you changed the fuel pump assembly but did you change the entire unit?

Just thought I would share my story in hopes it could help you out.
 

·
Registered
Joined
·
3 Posts
For the past month I have had an issue that has been perplexing me and my mechanic. I'll start up the truck, and after about 200 ft I come to a stop. The truck will dip below 500 rpm, and shake violently. It does it for 30 seconds tops. After that the truck will continue on as normal. The CEL came on, and was spitting the obligatory P0300 code. I took it down to my mechanic who did some work on it. I did some work on it too. This is what has been done so far:

All O2 sensors replaced
IAC valve cleaned
TB cleaned
Seafoam treatment

Even with all of this work done, it continues to do the same thing. I feel as though it may be idling a little heavy, but nothing like when I start it in the morning. I've heard that this problem could be a range of issues, from asymmetrical valve, to ignition coil. I thought I'd get y'alls take. Thanks in advance.
 

·
Registered
Joined
·
1 Posts
So after 7 months, and over $3k in work, my truck is fixed. It turns out it was one of the computers. They way I look at it, I will have very little to worry about for a long while. Thanks for all your input. It's been a rough past couple of months, but I'm glad my trucks is finally back to normal. :smileup:
Hey I’m not sure if you would respond but my truck is having the exact same problem, what computer was it?
 
21 - 26 of 26 Posts
Top