DODGE RAM FORUM banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi i am new to the site and this may have already been discussed if so just direct me to where to look not trying to be an annoying new thread starter. Anyway my 06 dodge ram 1500 w/ hemi just doesn't feel as powerful as i thought it would. I had an 04 silverado that had more punch in the pedal then this does. It has an AFE CAI installed by the previous owner and a stock exhaust. It has been showing an o2 sensor code havent corrected the problem yet maybe that is the answer not sure. Any advice on things to look into would be so awesome. I want to love my hemi but right now am a bit disappointed.
 

·
Registered
Joined
·
6,250 Posts
need to change that Y pipe as it is the bottleneck of the exhaust system... what exact code are you getting.. do you have a programmer yet, they make a big difference...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
no i do not have a tuner yet but the diablo is on my short wish list. And I was looking into exhaust today was thinking about just having the muffler removed then just running the duels back. thats what I did on my other truck and it sounded pretty good. the code is for the heated oxygen sensor 2/2 faulty at least thats what auto zone said. So what do i need in place of the ypipe.
 

·
Registered
Joined
·
6,250 Posts
you need an aftermarket Y..the stock one is pinched? Also, change your tstat to a 180 tstat.. you'll feel a little bit there... you don't want to just straight pipe it, it will feel even more sluggish...just change it out for an aftermarket muffler like magnaflow... also, do you know what gearing you have? might what to change them to 4.10's or 4.56's, what is the tire size you are running now?
 

·
Registered
Joined
·
6,250 Posts
or do something simple like resetting the pcm and drive aggressively so the pcm learns and makes everything more responsive..
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Tire size is 275/65/20 gears are 3.92 if resetting the PCM is disconnecting the neg batt cable I did that yesterday and been driving in tow haul and dogging it a lot more. amazingly I am getting better MPG.
 

·
Registered
Joined
·
6,250 Posts
i reset pcm by pulling fuse 23, turn the key to start position and hold (it won't start), wait til the seatbelt dings finish, then there will be a ding followed a few seconds later with another ding, confirms reset..
 

·
Registered
Joined
·
113 Posts
Has the truck been sitting around for a while? Mine was baby'd from the first user and while I appreciate it I have had to do some adjustments. Also with the o2 sensor shooting error codes the onboard computer will bog the engine down. Pretty standard since most cars after 97 in an effort to keep the factories from replacing burnt censors from people just avoiding the issue. I had this happen on an A4 20o2 and was explained this as well when the rear o2 sensor failed but the first refused to die (even 3 years later).
 

·
Registered
Joined
·
6,250 Posts
or... when was the last time you changed spark plugs and cleaned throttle body..sometimes the most simple stuff can be the obvious..
 
1 - 11 of 11 Posts
Top