DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've got a 13 ram 1500 with the dealer installed LED lights. It was saying that my right turn signal is out but its still working. I went ahead and changed both left and right tail lights and I was still getting the message until 2 days ago I started getting the message that the left turn signal is out instead of the right. I went ahead and changed my 3rd brake assembly out since I thought it was the brake light that started it all (changed that bulb a month ago and that's when this all started) the middle bulb looked like it recived to much power and blew up because of it. But after changing all three lights im still getting turn signal out message on dash every now and then but all the lights on the truck are working fine. Have anyone experienced this issue before?
 

·
Registered
Joined
·
9 Posts
I installed some alpharex headlights and everything was ok until I hooked up the daytime running lights, then I started getting the same message, ive read about it beforehand so I was prepared for it, aftermarket lamps must mess with the computer a bit.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I installed some alpharex headlights and everything was ok until I hooked up the daytime running lights, then I started getting the same message, ive read about it beforehand so I was prepared for it, aftermarket lamps must mess with the computer a bit.
Thats what I thought since my old 2003 didn't like aftermarket electronics at all. I put back all of my stock lights and im going to return the aftermarket ones since they didn't fix my problem. I honestly have no idea why I started getting the message
 
1 - 4 of 4 Posts
Top