DODGE RAM FORUM banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I need some help!!! on monday i drove my truck to work and all was well, when i got out of work my truck wouldnt start. When i hit the key the gages and everything would light up but as soon as i tried to turn it over everything would die. i ended up figuring out that it was a ground problem. i put a set of jumpers from the negative to the frame and got it to start. got it home and fixed the ground problem. now wensday thursday i noticed that the truck was turning over really slw, so i went to autozone and had them check my battery.. 100 percent charged and in good shape.. they also checked the starter, and it was ok.. they ended up diagnosing that the voltage regulator was bad in the altinator.. soo i got a new one and put that in i thought it fixed the problem.. but today (friday) after work i go to start it and it turns over slow, starts, but then dies.. try it again same thing.. finaly i started it and gave it gas and it reved up running just fine but when i let outof the gas it died right away.. (same scenario when my battery kicked the bucket about 3 months ago) to make a lng story short i started it and held it above an idle for about a min and let out and it ran like nothing was wrong.. i guess im lost as to what would cause all of this and if someone could help me out it wold be greately appreciated..
thank you for your time,
Chance
 

·
Registered
Joined
·
5 Posts
I was just wondering if it was showing a code. Autozone will hook it up and check for free. Also, how did you fix your ground problem?
 
1 - 2 of 2 Posts
Top