DODGE RAM FORUM banner

1 - 17 of 17 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey everyone. I have a 05 Ram 1500 with the infinity sound system. My problem is that the front speakers have no sound coming from them. First I thought the speakers were messed up, but as I pulled out of my driveway the other day, magnificent sound came from the front speakers. As soon as I hit another bump, it cut out again. I found a thread about where the amp is, but I cant figure out how to get it out, I tried to play with the connector to see if it was loose but doesnt appear to be. Any tips on how I can get my factory system to play.

PLEASE HELP :) I love music, and its killing me only having the highs and mids producing sound.

Thanks
 
E

·
Guest
Joined
·
0 Posts
The document attached may help you get the amp out. Sounds like (no pun intended) that you either have a connector loose at the amp or at the speakers.
 

Attachments

·
Registered
Joined
·
28 Posts
Discussion Starter #4
I have checked the connection at the speakers and everything seems fine there. I dismantled part of my dash and found the amp on my last rotation off, but my hands are too big to slide in there so I have to make it more accessible. I'll try it again on my next days off, TY. If its a fried amp I'm not sure where to find another one. I really dont want to have to install a complete aftermarket system, factory is fine for my taste. I'll let you know how it goes though... Thanks again.
 
E

·
Guest
Joined
·
0 Posts
If it comes on and off with a bump, i suspect you just have a loose connection at the back where the harness plugs in.

If the amp is fried, you can get a factory replacement.

I know what ya mean about how tight it is back there!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
Hey yall, well I played with the connector on the amp behind the airbag today... No Joy... still no sound from my front speakers... Does anyone know of a way to check if the stereo is putting consistent power to the amp... Since the brief experience of having sound come out of the speakers when I hit the end of my driveway, I am assuming that the speakers are good... I unconnected the stereo harness and reconnected it... Still nothing, but in the past week I have turned my stereo on and it wasn't able to pick up any radio stations, but was able to play and cycle through the 6 discs... The antennae is connected and in all the way... Any ideas on how I can fix my factory stereo? Also if it is the amp where can I find one without going through the overpriced dealership?

Thanks for any help you all can provide...
 
E

·
Guest
Joined
·
0 Posts
Sounds like the amp is partially fried on the input side or has an intermittent short in it.

You might consider upgrading to the Kicker OEM accessory amp, part number 77KICK18AB, if it's determined the Infinity amp (which I detest) can't be fixed. Price is around $175 and a couple of Mopar super sellers online have them at that price. Normal dealer price on that unit is $210. I have on in my SRT8 along with some upgraded speakers (Infinity Kappa Series) and it sounds great!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
Sweet, Thanks MADDOG... I didn't realize the kicker OEM parts were interchangeable, I'll check with a stereo shop about making sure my head unit is still working good and then I'll go ahead for the kicker amp... I had also found a kicker sub and OEM amp assembly that goes into the storage area under the middle front seat...
 
E

·
Guest
Joined
·
0 Posts
Score!!!! The Kicker OEM sub amp is pretty wimpy. I replaced mine with an Alpine 500W mono amp in the car. I may go two 10's in the truck behind the rear seat (it's a megacab so there's room).

Kicker also has a full set of OEM accessory speakers for the trucks that are available from dealers or online sellers. I know they have no impedance issues with the Kicker accessory amp.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #12
Sorry took so long for a response, but here is the dumb question... Where do I find the ground for the amp? I know I'm not educated enough to dismantle my entire interior in search of the 1 loose wire, so is there a place I should look?
 
E

·
Guest
Joined
·
0 Posts
I havent' torn mine apart so I'm not sure where it is but it's gotta be attached to the amp on the backside.

I'll know soon...when my amp and spkrs get here, I'm diggin' in to the dash!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #15
Can't wait

Ok, So I finally got off my A$$ and ordered the kicker factory replacement amp and Kicker upgrade speakers front and rear (upgrading the rear to 6x9's) and UPS will have them here tomorrow, Monday October 11. So I will let yall know how it goes once they are in tomorrow.
 

·
Registered
Joined
·
2,190 Posts
Cool, good luck! So what's goin on with the radio?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #17
@Juice - The stereo had quit playing music through the front speakers.

Installed the Kicker upgrade speakers throughout, but something was wrong with the Kicker Amp, as in when I plugged it in you could see the light on inside of the amp, but NO SOUND. :4-dontknow::4-dontknow: So I have to figure out whats up with that... But on a good note I do have sound, all around again, just not as much power as I'd like.
 
1 - 17 of 17 Posts
Top