DODGE RAM FORUM banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hey everyone! I'm having a bit of a issue with my truck since January 2021 it's now October 2021
Back in JanuaryI had my serpentine belt replaced. The same day thatI had the belt doneI started experiencing a strange vibration when I'm coasting or steady speed. It doesn't matter what speed I'm going this feeling comes from the right side of the truck like driving on the emergency strips. IfI give the truck gas or press on the brake this strange feeling goes away. I also have a delay going into 2nd and 3rd gears, truck shifts smooth as butter, just waits about 5 seconds to shift in those gears. When braking rpms will slightly rise, but not bad. I also notice when driving over 65 mph truck bounces bad like it needs tire balancing, but just put new tires on and had balanced, I even had tech put heavier weights on tires because of this issue. Now there's NO emergency lights on in the truck, no check engine etc. So, I took it to two different places. One being the dealership where they stated it was my torque convertor, This was back in January andI had the Trans fluid changed that same day, to see if it would help. Symptoms stayed the same. It hasn't gotten worse or better. But has its days where it will act up more than some.

I then proceeded to take to my local tech and they hooked the truck up on this machine they call "Lucy" of course the machine found nothing wrong. But my local tech did say my rim on the right passenger side is slightly bent. Maybe this could be causing the issue weird vibration feeling. I'm about to lose it seriously! I've bought the torque convertor it's been sitting in my garage since January, but I highly doubt this is the issue. Something tells me it's the TPS sensor or something small causing this issue. Its paid off and I really don't want to have to throw $2k to get a torque convertor installed then that not be the issue. Dealer even said that he couldn't really tell the issue because no check engine lights are not on, but basically guessing.

Has anyone else had this strange issue? I feel like I'm the only one with a weird truck. Lol

Tire Wheel Car Automotive parking light Land vehicle
 

·
Registered
Joined
·
5,496 Posts
Sounds like you have a couple of problems that are not related to each other. Lets start with the vibration. One person told you the rim was bent. Change the position of that tire/wheel to a rear on the opposite side of the truck that you are sensing the vibration and see if the vibration moves. Trans shifting slow might be the torque converter. You have one in the garage, get it changed. Truck bouncing could be bad shocks.
 

·
Registered
Joined
·
1,070 Posts
Sounds like you have a couple of problems that are not related to each other. Leets start with the vibration. One person told you the rim was bent. Change the position of that tire/wheel to a rear on the opposite side of the truck that you are sensing the vibration. Trans shifting slow might be the torque converter. You have one in the garage, get it changed. Truck bouncing could be bad shocks.
Any and or all of the above are great places to look.
 

·
Registered
Joined
·
1,070 Posts
If the tech put more weight on your wheels at your suggestion,I would find a better tech . The tires are balanced or not , no just add more cause the customer said so. You should search ,ask friends and relatives for a competent shop .
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thank you for the responses. I did have the tires rotated, but not sure if they took the bad rim from the front and put it on the back.
The weights were changed around 3 times. Not sure why the truck is still bouncing. I've had new struts and wheel bearings about a year ago put on.
My transmission started acting up right after new serpentine belt was installed, do you think that lose or bad belt could be the issue?
 

·
Registered
Joined
·
3 Posts
Thank you for the responses. I did have the tires rotated, but not sure if they took the bad rim from the front and put it on the back.
The weights were changed around 3 times. Not sure why the truck is still bouncing. I've had new struts and wheel bearings about a year ago put on.
My transmission started acting up right after new serpentine belt was installed, do you think that lose or bad belt could be the issue?
Check the tire "roundness" . I had the same issue, Dealer did nothing. I measured every aspect from the hub center out , and it turned out the tires were out of round up to .320" in some areas. Goodyear finally replaced 3 of the four " out of round" tires and the issue went away. Needless to say it took a lot of back and forth to get the issue resolved.
 

·
Registered
Joined
·
8 Posts
I bought 4 brand new tires, and after attempting ”Road Force Balancing” , one of the tires could not be balanced (it was out of round) They were Goodrich TA All terrains that I ordered from Amazon, and they sent me a new tire within 2 days.
Make sure your shop is using “Hunter Road Force Balancer “ machine, they cost a bundle, but a good shop should have one.
 
1 - 9 of 9 Posts
Top