DODGE RAM FORUM banner
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey yall..Got a few wierd things going on with my new sport 1500.
1- At idle if the trannys got any bind on it, like foot lightly on the brake or turning hard, the tranny shimmys/pulsates pretty good.

2 - between 40-50 mph if its coasting in im guessing 5th gear?, when you start acclerating again it gets a wierd binding/grinding feel to it, it pops, doesnt down shift, but after the pop it smoothes out and all is well.


I had an 05 hemi before this truck and it was awesome, this ones just got some wierd vibes to it. It does have the 3.92 rear end in it. Wondering if thats just freaking me out getting used to it.

Thanks !
 

·
Registered
Joined
·
564 Posts
Mine does the same I've come to the conclusion it's normal mines a hemi reg can exspress with 3.92 gears.
 

·
Registered
Joined
·
487 Posts
Hey yall..Got a few wierd things going on with my new sport 1500.
1- At idle if the trannys got any bind on it, like foot lightly on the brake or turning hard, the tranny shimmys/pulsates pretty good.

2 - between 40-50 mph if its coasting in im guessing 5th gear?, when you start acclerating again it gets a wierd binding/grinding feel to it, it pops, doesnt down shift, but after the pop it smoothes out and all is well.


I had an 05 hemi before this truck and it was awesome, this ones just got some wierd vibes to it. It does have the 3.92 rear end in it. Wondering if thats just freaking me out getting used to it.

Thanks !
I have the same set up and have never experienced such issues. I highly doubt the gears in the rear end would make any difference. Have the dealership check it out.
 

·
Registered
Joined
·
55 Posts
My Express did it noticeably when brand new. 1800 miles now, less noticeable (in fact, barely noticeable). Same with the clunk. Very obvious when coming to a stop when brand new, have to listen for it now.

Hopefully just something that diminishes with break-in.
 

·
Registered
Joined
·
2,523 Posts
Hey yall..Got a few wierd things going on with my new sport 1500.
1- At idle if the trannys got any bind on it, like foot lightly on the brake or turning hard, the tranny shimmys/pulsates pretty good.

2 - between 40-50 mph if its coasting in im guessing 5th gear?, when you start acclerating again it gets a wierd binding/grinding feel to it, it pops, doesnt down shift, but after the pop it smoothes out and all is well.


I had an 05 hemi before this truck and it was awesome, this ones just got some wierd vibes to it. It does have the 3.92 rear end in it. Wondering if thats just freaking me out getting used to it.

Thanks !
I'm not sure I understand point 1. Is this when sitting at a stop, or while moving?

Point 2 sounds like truck coming out of MDS, or unlocking the converter (which would be normal behavior).
 

·
Registered
Joined
·
834 Posts
My tranny shutters at WOT between 40-55 mph when it down shifts. I read it's because of factory programs in the tranny? Some say there is a new flash to improve drive ability.
My 2010 does the very same thing if I'm cruising at 40-50, and MDS is activated - if I punch it to downshift, it'll shudder and try to downshift but won't....I end up having to let off completely then hit it again. Doesn't do it all the time, and I haven't taken the time to try and duplicate for the dealer. Plus, I don't know if there's a flash that fixes it.
 
1 - 9 of 9 Posts
Top