DODGE RAM FORUM banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Let me just start by saying that I make zero claims of being a mechanic.

My AC has been acting up on me and here in Texas the heat has been well north of 100° (people have been posting pictures of their vehicles saying 115°+/-) and that's a bit too hot to be working in the sun just to get in a truck with no AC.

That being said, I started with the blower motor. I hooked a brand new one up and it still wouldn't blow (I hooked mine directly to a battery and it spun just like a new one). I drove an hour to a store that had a resistor in stock. Bought it and changed it out. Nothing. My 40A fuse is not blown (although I did change it first a month or so ago and it worked for probably 3 or 4 days before blowing again). I found a relay on the Auto Zone website which they pulled for me and it was identical. I changed it out and boom, it worked. Before I could get out of the parking lot it stopped again. Drove back home roughly an hour or so and it would kick in and blow cold for 5-10 minutes at a time and then just completely stop. It did this probably 3 or 4 times.

Again, I'm not a mechanic. Is there something I'm completely missing or that I should have looked at first? I'm 28 years old and I'm in the middle of a start-up company. My schedule stays booked and I don't have time to leave it at a dealership or shop for a week and I have zero desire to kill myself by getting overheated.

Any help/guidance is greatly appreciated.
 

·
Registered
Joined
·
2 Posts
I was wondering if anything has come out of this post? I'm experiencing the exact same thing. My climate controls on the dash are working, the blower motor is working, the original resistor has the same test readings as the new one that I purchased and installed, yet the blower motor will not turn on like it should. The only thing I have left to check is the wiring harness that runs from the passenger side footwell up around the back of the heater box. But I don't want to get into removing the entire Dash and heater box if I should be looking somewhere else first for the issue. I have a 2011 Ram 3500 6.7 Cummins. When the truck was parked almost a month ago everything was working fine, but when I started it this weekend cuz I needed it I realized quickly I had no AC, which turned into no blower motor! If anyone is able to help out in any way it would be greatly appreciated. As I am also having a very difficult time finding a wiring diagram for the HVAC system.
 
1 - 2 of 2 Posts
Top