DODGE RAM FORUM banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey all,

I have a strange brake issue with a 2500 heavy-duty that I can't figure out. I've read through multiple posts here but haven't found anything to help with what I've got.

So I have the front drivers brake caliper dragging. It starts out small but the more it drives the worse it gets, from the heat build up I would guess. So far here is what has been replaced or done...

Pads, caliper, rotor, both sections of rubber hose, complete fluid flush and change.

Still having the drag issue, what would be next on the list to check?

Thanks,
 

·
Registered
Joined
·
1,655 Posts
Sounds like you have changed things back to the ABS module, sooooooo. Are the slide pins free? Move easily? I hate to ask but the bleeder is at the top of the caliper right? What kind of bleeds have you done? You may have to bleed with a scan tool to run the ABS module while bleeding. I would have to check.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Pins slide freely, caliper came with a new mount.

Bleeder is at the top of the caliper, did the standard bleed with a helper pushing the pedal, also did a vacuum bleed after that.

Not sure what you mean by running the scan tool during the bleed
 

·
Registered
Joined
·
1,655 Posts
So my next thought is drive it and get to point it drags. Then put a wrench on the suspect caliper and see if pressure is built up. Then if there is have to work from there. If no pressure then it has to be a mechanical friction problem rite?
 

·
Registered
Joined
·
9 Posts
I have a caliper on the LF sticking. Wheel got very hot and I could smell burning. Took it to shop and they said I need a new master cylinder and brake booster. They are going to put new brake lines on the front too. Look at your master cylinder, mine has had brake fluid dripping from it for some time.
 

·
Registered
Joined
·
9 Posts
@JCrerand I have a VERY similar problem with my 2015 Ram 1500. Did you ever figure it out. Mine is sporadic, which makes it difficult to diagnose. I've replaced all calipers, front hoses, front bearings, still happens. Took out the ABS fuse, still happens.
 
1 - 8 of 8 Posts
Top