DODGE RAM FORUM banner
1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hi Guys

I am getting the following codes and have replaced the Camshaft Position Sensor myself already.

P0344 - cam shaft position sensor intermittent. Bank 1 sensor 1. (Still getting this code after replacing with a new OEM sensor)

U1424-00 - implausible engine torque signal received

P1DD2-00 - torque request signal from TCM (Transmission control module) denied

C121C-00 - torque request signal denied

I’m guessing these are all related to the powertrain control module a.k.a. transmission control module?

If I replace it myself, is it as simple as just removing the old and replacing with the new? It looks very straightforward to do. Do I have to have anything re-programmed from the dealer?

Any other advice based on these codes is very much appreciated!

Thank you,
Shawn
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #4 ·
If anyone ever runs into this check your oil level. According to the dealer I brought it to that was the only problem. What’s really confusing is how I was low on oil. However, once it was topped off all these sensors lights went away
 

·
Registered
Joined
·
5,505 Posts
If anyone ever runs into this check your oil level. According to the dealer I brought it to that was the only problem. What’s really confusing is how I was low on oil. However, once it was topped off all these sensors lights went away
MoBigsley, sorry I missed this post when you originally posted it.


Thanks for the update. That is an interesting result. Like you, I myself do not see how low oil could have caused your symptoms. I would look at the under side of the truck and see if it is oil covered from a leak. If not you might be burning it through the engine.

Here is a You Tube video on this subject with comments from other people. The video is kind of boring but the comments are good.

 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
No oil leaks under the vehicle, and I change the oil myself and know with 1000% certainty it was filled properly at my last oil change
 
1 - 6 of 6 Posts
Top