DODGE RAM FORUM banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2017 Ram 1500 Laramie Crew Cab with 28,000 miles on it. The backup camera works about 60% of the time. When it's not working I either get squiggly lines, green screen or just a black screen. I took it into the Chrysler dealership for a normal oil change and told them about the issue. Sure enough, this was a day where the camera was woking fine with no issues. The Dealership said that since they couldn't replicate the issue with the camera there wasn't anything they could do. I also called RAM and they said there wasn't anything they could do unless the mechanic found an issue. So now I have a backup camera that works 60% of the time and the dealership or RAM wont do anything about it. I'm approaching my warranty very soon. ANY ADVICE??
 

·
Registered
Joined
·
5,505 Posts
Check the tailgate plug under the truck. It should be in about the middle of the truck next to/above the spare tire. It has been known to cause problems. Try disconnecting it and cleaning it with spray electrical cleaner then use dielectric grease when yo put it back together.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Check the tailgate plug under the truck. It should be in about the middle of the truck next to/above the spare tire. It has been known to cause problems. Try disconnecting it and cleaning it with spray electrical cleaner then use dielectric grease when yo put it back together.
Thanks for the reply. I can try that, however I'm looking for a solution that involves the dealership/chrysler actually honoring their warranty.
 

·
Registered
Joined
·
5,505 Posts
Like they say, they can't do anything unless they see the problem. If you are wanting them to do something, wait until it screws up then go to the dealer.
 

·
Registered
Joined
·
2,390 Posts
I have a 2017 Ram 1500 Laramie Crew Cab with 28,000 miles on it. The backup camera works about 60% of the time. When it's not working I either get squiggly lines, green screen or just a black screen. I took it into the Chrysler dealership for a normal oil change and told them about the issue. Sure enough, this was a day where the camera was woking fine with no issues. The Dealership said that since they couldn't replicate the issue with the camera there wasn't anything they could do. I also called RAM and they said there wasn't anything they could do unless the mechanic found an issue. So now I have a backup camera that works 60% of the time and the dealership or RAM wont do anything about it. I'm approaching my warranty very soon. ANY ADVICE??
Hi kcrumb31,

I'm very sorry to hear of the trouble you are experiencing with your truck. If you do plan to proceed with a formal diagnostic appointment, please let us know via private message. We would be more than happy to provide you with an additional layer of support for that process.

Mark
RamCares
 

·
Registered
Joined
·
34 Posts
I have a 2017 Ram 1500 Laramie Crew Cab with 28,000 miles on it. The backup camera works about 60% of the time. When it's not working I either get squiggly lines, green screen or just a black screen. I took it into the Chrysler dealership for a normal oil change and told them about the issue. Sure enough, this was a day where the camera was woking fine with no issues. The Dealership said that since they couldn't replicate the issue with the camera there wasn't anything they could do. I also called RAM and they said there wasn't anything they could do unless the mechanic found an issue. So now I have a backup camera that works 60% of the time and the dealership or RAM wont do anything about it. I'm approaching my warranty very soon. ANY ADVICE??
I had the same problem with my 2014 1500. I was able to get it to fail with some regularity by opening and closing the tailgate prior to starting the vehicle. So what airforce26years stated about the tailgate plug may hold some water. However, like you, I could never get it to fail when at the dealership and I just stopped taking it in for that issue. Good luck, wish I had more to contribute.
 

·
Registered
Joined
·
8 Posts
I had the same issue on my 2017 Ram Sport 4x4. Finally it acted up when I was driving near the dealership. I stopped and the service advisor saw the squiggly lines and immediately authorized a new camera. They had one in stock and replaced it in about 10 minutes. I had 35000 miles on my truck, just made the warranty, lucky because the parts guy said that it sells for 485 bucks.
 

·
Registered
Joined
·
39 Posts
Mine did that also so I removed the panel on the inside of the tailgate and opened up the plug thar is attached to the tailgate from camera. put some dielectric grease in it and it has worked fine ever since
 

·
Registered
2017 Ram Laramie 4X4 Crew Cab
Joined
·
5 Posts
I've had the same issue on my 2017, opened up the tailgate panel and checked my connections and slipped a little electrical grease in and it worked fine afterwards. Have had the image scrambled and green screen after wet weather. hopefully no further issues.
 

·
Registered
Joined
·
5 Posts
I have a 2017 Ram 1500 Laramie Crew Cab with 28,000 miles on it. The backup camera works about 60% of the time. When it's not working I either get squiggly lines, green screen or just a black screen. I took it into the Chrysler dealership for a normal oil change and told them about the issue. Sure enough, this was a day where the camera was woking fine with no issues. The Dealership said that since they couldn't replicate the issue with the camera there wasn't anything they could do. I also called RAM and they said there wasn't anything they could do unless the mechanic found an issue. So now I have a backup camera that works 60% of the time and the dealership or RAM wont do anything about it. I'm approaching my warranty very soon. ANY ADVICE??
5k miles on my 2019 Ram tired of trying to deal with this issue but will try the tailgate plug.
Electronics Technology Electronic device Multimedia Screen
 
1 - 10 of 10 Posts
Top