DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have a 2019 Ram Rebel($62K) with a 12" Uconnect system that has had on and off issues from the beginning... at first I did not recognize them as something was wrong with system because of the new system. When I figure enough is enough I contacted Uconnect and got a case manager Sherri , who walked me through a bunch of fixes that did not work, finally said you need a software update 08-009-19 REV. B "and this should fix all your issues"...
Made an appointment (1/17/2020) with local dealer who did the update and a few recalls, along with oil change, tire rotation , etc. Said everything was fixed and good to go.
On drive home which is almost a hour, the 12" NAV started to act up, rear camera would come on and would not go off for a long period of time than went off on its own. All the route numbers on Nav screen where all little black boxes.. Got home called dealer..... They said bring it back and we will reinstall the update and find the bad files and fix them... so drove a hour back, sat around in waiting room for a hour or so, Parts guy(Richard) comes out to get me hands me keys says we can not fix it and update did not work, I have ordered a new RADIO with no ETA.
Couple weeks later get a call or I call ( I forget) Uconnect say the are not replacing radio I need to go back to dealer for a new update.....I did this on Feb 3, 2020 (monday)..
I get a call Feb 4, 2020 saying they can't fix it and they are waiting for STAR ( who ever that is) to make a decision. Got a call Feb 6 from Uconnect case manager Laura ( who I have been calling all week , with no response,) since she and the dealer originally said they unit was bad and they were going to replace it, now saying they are not going to replace it and I need to wait for the next update that "should" be out in the next quarter and that "should" fix all the issues. Later that day Feb 6, dealer (Garry) calls with the same news. No ETA on new update but they need the loaner back and they want me to come and get the UNSAFE truck and drive it around until the new update is available.
Well the first 3 attempts did not work and actually cause other issues that the dealer says are not related like my sensors would go off on there own. While driving the front sensor would go off like I was ready to hit something and stay on till I pulled off road and turn truck off. The rear camera would pop up on screen while driving and could not get it off... than on its own would go off . many other things I will not bore you with.. dealer said there was a new sensor update they did on this Feb 3rd trip said should fix those problems ( not sure why they did not do it on first failed update attempts).
I am done fooling with RAM, Uconnect, STAR (who ever they are) anylonger and will be contacting a lawyer on Monday to pursue a Lemon Law case and a buyback... Now I need to go and pick up this $62 K piece of crap and see what they screwed up on this failed update ... VERY FRUSTRATED with RAM and there lack of customer services... going back to FORD.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Now the dealer ( Gary) in service will not provide me with paperwork that there service department worked on my truck a second time for a complete new issue with the Nav unit because it was on the same day.

First time I paid my bill, that should have closed out my ticket. A couple hours later I had different issues I called dealer and was told by Richard ( service manager) he would set up another appointment to try and fix the problem, I ask if they had time that day, he check and said yes. I got back in my truck and drove a hour back to dealer, they worked about a hour and like above Richard came into waiting room handed my keys and said he ordered a new radio which now seems no one has a record of. I asked for the paperwork on my SECOND visit and wanted documentation on what they did and that they had tried and failed again.... when I came to pick up my truck the 3rd time

Gary said he had found Richard's paperwork on the phone, cause I had him find it and have it before I went down and wasted more time. When I went down they handed me what I already had which was the first failed attempt and said there was no other paperwork, Richard did something for a hour that did not fix the problem and I wanted documentation which they will not supply.

PLUS the paperwork today did not have ANYTHING on what they did that STAR sent me there to have done on the Uconnect system, Gary said they did not do anything.. REALLY that was the reason I had to return... and Gary would not let me speak to a manager until another service guy went on his own and got the Parts manager after me waiting 30 minutes standing at counter. Just piss poor services ( Richard the service manger was out recovering from surgery will be back next week) I did talk to Clark the Parts manager who was a super nice guy and said YES they did work on it again and he said he did not know why it was not included on the paperwork, but he said to wait in his office and he would get it done.... The second failed attemp with Richard he had to look into cause there was no record of me coming back a second time... I said ask Richard and the Tech who worked on it.... I am waiting now, Clark said he would get back to me.. The Dealer is Fred Frederick, Easton Maryland
 

·
Registered
Joined
·
157 Posts
Good luck, I do hope that you get this resolved. But going back to Ford? NOT. My sister In-law came over in her new Ford, would even let her park it in the driveway. I offered to pick her up from the local Meijer's parking lot so it wouldn't even disgrace the front of my house. They say that 75% of Fords are still on the road, you know why? because people just abandoned them their when they broke down. Happy Sunday everyone, spring is coming.
 

·
Registered
Joined
·
286 Posts
Yeah pretty common. I brought truck in because AA and carplay wouldn't work basically media ports would only charge. They diagnosed it short in radio. New radio would take 2-3 weeks. OK I called 2 weeks later a d was told they JUST heard FCA denied radio and need to open star(technical service request), called 1.5 weeks later and they JUST heard that star wanted more testing done. I went down in the morning and they asked to keep it for the day and put me in loaner. I received call that everything is working. I went and confirmed it was working. I suspect update was performed even though they claim nothing was done. Pretty odd considering it didn't work for almost the past 4 weeks. 2020 have been getting OTA updates this past week so hopefully 2019 updates will follow ???
 

·
Registered
Joined
·
2 Posts
Now the dealer ( Gary) in service will not provide me with paperwork that there service department worked on my truck a second time for a complete new issue with the Nav unit because it was on the same day.

First time I paid my bill, that should have closed out my ticket. A couple hours later I had different issues I called dealer and was told by Richard ( service manager) he would set up another appointment to try and fix the problem, I ask if they had time that day, he check and said yes. I got back in my truck and drove a hour back to dealer, they worked about a hour and like above Richard came into waiting room handed my keys and said he ordered a new radio which now seems no one has a record of. I asked for the paperwork on my SECOND visit and wanted documentation on what they did and that they had tried and failed again.... when I came to pick up my truck the 3rd time

Gary said he had found Richard's paperwork on the phone, cause I had him find it and have it before I went down and wasted more time. When I went down they handed me what I already had which was the first failed attempt and said there was no other paperwork, Richard did something for a hour that did not fix the problem and I wanted documentation which they will not supply.

PLUS the paperwork today did not have ANYTHING on what they did that STAR sent me there to have done on the Uconnect system, Gary said they did not do anything.. REALLY that was the reason I had to return... and Gary would not let me speak to a manager until another service guy went on his own and got the Parts manager after me waiting 30 minutes standing at counter. Just piss poor services ( Richard the service manger was out recovering from surgery will be back next week) I did talk to Clark the Parts manager who was a super nice guy and said YES they did work on it again and he said he did not know why it was not included on the paperwork, but he said to wait in his office and he would get it done.... The second failed attemp with Richard he had to look into cause there was no record of me coming back a second time... I said ask Richard and the Tech who worked on it.... I am waiting now, Clark said he would get back to me.. The Dealer is Fred Frederick, Easton Maryland
I recently switched from Ford to now be a Dodge guy, for similar issues. Owned three Ford trucks and got tired of shoddy, money-grubbing, lying dealerships so was hoping the change would be for the good. It sucks you're having all these issues but you might want to 1) Contact Ram directly and make a complaint and 2) post this on your dealership's Facebook page. You'd be surprised how fast some places want to help once you start calling out their bullshit on social media. Best of luck.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
I recently switched from Ford to now be a Dodge guy, for similar issues. Owned three Ford trucks and got tired of shoddy, money-grubbing, lying dealerships so was hoping the change would be for the good. It sucks you're having all these issues but you might want to 1) Contact Ram directly and make a complaint and 2) post this on your dealership's Facebook page. You'd be surprised how fast some places want to help once you start calling out their bullshit on social media. Best of luck.
I have sent cerified letter to both FCA and Consumer Protection Division

the UPDATE is I had to take it back Tuesday 02/18/2020 for a number of issues, air condition comes on when heat setting is at 75. Nav screen has things popping up on there own than disappearing, I even took picture of it happening driving to dealer, Gary the service guy really did not even want to look a them, Again they said in the report when it was done , they can't fix anything and I need to wait for up date.
I have been having a issue with in reverse with nothing behind you truck will just slam on the brakes a big red BRAKE will show up on the screen in front of steering wheel, that was on my list I gave to Gary who woulld not even look at it and was not addressed at all during this visit, last night trting to pull out of Royal Farms store it did it 4 times in a row, was not sure I was getting out of parking lot .

Sent email to Richard service manager who was temperarly back from surgery when I was there 02/18/2020, he had the emails he ordered the radio and was over ridden by Star, he said YES he remembered making the second appointment with me. Said he would address the problems out in his service area. He had been out recovering from surgery for a while and things are falling apart with out him being there.
 
1 - 6 of 6 Posts
Top