DODGE RAM FORUM banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I've got a 2019 RAM 1500 with a series of uconnect issues that I seem to be getting nowhere with. It's the 8.4 with nav variety, which isn't working correctly as in XM guardian not functioning reliably via the SOS or assist, some system controls/apps sometimes don't appear, radio skips whether it's XM or Bluetooth, and there are issues with items otherwise set via the controls via the uconnect like the parking brake do not always work. The auto parking brake, for example, works about half the time - which is obviously a safety issue. When the dealer looked at it, they came to the conclusion it should be replaced. However, in spite of my attempts to work with the dealer and RAM. I've not gotten a replacement/resolution. Is there some reason neither the dealer or RAM seems to be unable to fix this?
 

·
Registered
Joined
·
1 Posts
I've got a 2019 RAM 1500 with a series of uconnect issues that I seem to be getting nowhere with. It's the 8.4 with nav variety, which isn't working correctly as in XM guardian not functioning reliably via the SOS or assist, some system controls/apps sometimes don't appear, radio skips whether it's XM or Bluetooth, and there are issues with items otherwise set via the controls via the uconnect like the parking brake do not always work. The auto parking brake, for example, works about half the time - which is obviously a safety issue. When the dealer looked at it, they came to the conclusion it should be replaced. However, in spite of my attempts to work with the dealer and RAM. I've not gotten a replacement/resolution. Is there some reason neither the dealer or RAM seems to be unable to fix this?
RedBeard69, did they ever get this resolved for you?

I just bought a new 2019 Ram 1500 Classic June 19, 2020, and am having similar issues. My radio says that I need to activate my subscription, but when I called XM Guarian or Uconnect, they said my subscription is active. So, the SOS button doesn't work, the app store won't work, the Vehicle History Report on Mopar.com won't work, and the Uconnect App keeps failing when I go to look at my Vehicle Info.

I dropped it off with the local dealer here July 1, and they have been working on it since. Between the Service center, an FCA Star Case, and XM Guaridain, they can't seem to get it figured out.

The service Technician wants to replace the radio, but FCA won't let him. Says he has to work with a special team at FCA, and this is dragging out.

Between the check engine light issue for the EGR Cooler the day I drove it home and having to let them work on that for the first three days I owned the truck and the current radio issue my brand new truck has been in the shop for 14 days out of the 21 I have owned it. Thinking about calling a Lemon Law lawyer...

If anyone has any advice or info related to the 8.4 with nav radio it would be greatly appreciated.
 
1 - 2 of 2 Posts
Top