DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I did the 318 to 360 swap on my 2001 dodge ram, I changed the torque converter and everything else but my problem is the gas pedal is almost to the floor, and it sputters real bad when you try to rev the motor with the pedal and will slowly rev up to about 3200 rpm, but when you rev it at the throttle body it revs just fine and wraps out the motor, does anybody know what the problem could be?? Its my daily driver, and I told my dad it would only take a week to do the swap and have it driving again...that didnt work too well, Im just wondering if anybody knows what the problem could be? Or has had the same problem?

Any tips would be greatly appreciated
 

·
Registered
Joined
·
8,249 Posts
Welcome to the site; I don't have an answer so, it's time to .........:icon_bump:........... this back to the top! Drop by the Newbie Checkin and introduce yourself. Hope to see you around!
 

·
Registered
Joined
·
1,068 Posts
sounds like you put the cable on the wrong spot on the throttle linkage.

Thats really all it could be if it revs fine at the throttle body.

Linkage should be hooked up like this...can't really see it...but...basically...

 

·
Registered
Joined
·
13,690 Posts
I don't know for sure, but just keep in mind if you are saying that it revs slow/poorly when driving it vs sitting in park....the engine operates totally different under load. If you are saying that it revs poorly/slowly in park with the pedal...then it has to be like he said above, the linkage.
 
1 - 4 of 4 Posts
Top