DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys, I have a 2017 Ram 2500 Laramie with 6.4/ 66RFE (I believe) and 4.10 posi-axle. 26k on the truck, original owner.

It's always had a couple minor quirks (like the coolant smell under the hood the dealer still can't figure out), and the trans has always had a 5--->4th clunk on deceleration. Originally, it happened infrequently. Lately, it's happening more often...like I can do it 50% of the time if I try.

Truck is bone stock other than an AFE intake and a pedal commander (which was not installed until about 15k miles, so it definitely clunked before install). If I put the trans in "manual" mode, I can see the current gear, and believe it clunks when it enters 4th on slight deceleration from a 6th gear cruise (6-->5 is smooth, 5--->4 clunks as if someone bumped the rear end).

Has had all 152 recalls fixed (exaggerating, LOL) but never had any trans work done.

Any thoughts on what it could be?
 

·
Premium Member
Joined
·
32,659 Posts
Several years ago, Ram had an issue with cheap Chinese upper & lower radiator hoses
Once the coolant reached operating temperature something happened chemically to the hoses & a terrible smell occurred. That smell went into the cab vents & was bad enough to make some people in the cab ill.

I don't think any Ram as new as yours was part of that, i think that it was more for 2012 Rams
 

·
Registered
Joined
·
103 Posts
My 2016 with same powertrain has the same issue with the smell along with a rattle at idle on #5 and #7 area . My trans not only has the 4-5 issues but also likes to hold itself in 3rd occasionally as well and when it does it will not shift into 4th until 4500-5000 rpms and it does not do it smooth. I have pretty much gotten to the point of just running the snot out of it and waiting for the thing to blow up because that is the only way Ram and FCA is going to ever have to admit there is an issue and they will still fight fixing it because everything is normal and operating as it should.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
My 2016 with same powertrain has the same issue with the smell along with a rattle at idle on #5 and #7 area . My trans not only has the 4-5 issues but also likes to hold itself in 3rd occasionally as well and when it does it will not shift into 4th until 4500-5000 rpms and it does not do it smooth. I have pretty much gotten to the point of just running the snot out of it and waiting for the thing to blow up because that is the only way Ram and FCA is going to ever have to admit there is an issue and they will still fight fixing it because everything is normal and operating as it should.
Sounds about right, LOL. How many miles on yours? I've had more issues with this 17 than with my previous 13 and 15 Cummins trucks, but financially, I'd really like to keep it. I've got the 100k extended warranty on it, so I've got some time yet.

So far:
Blue smoke upon startup for the first 10k miles, also drank a solid quart every 3000 miles until about 15k, now that has subsided. Clatter when stone cold, goes away pretty quick. Not sure if Hemi tick or what. Trans shifts like garbage sometimes (mainly the --->4 downshift, but also sometimes the -->2 or ---> 1 Downshift. I've had it hold 2nd or 3rd at redline a couple times towing a trailer uphill, and it literally would not upshift until I slowed down and then tried again. Kinda odd, but whatever. Driver's window rattles, driver's lumbar was just replaced and the leather bolster and radio knobs (I know, seems silly) hasn't held up nearly as well as the previous 2 trucks......I'm just wondering how much cost cutting has gone on.

Otherwise, I do like the truck. Dealer offered me payoff on trade towards a 2019 1500 Hemi which has a smoking lease rate right now, but it's gonna be marginal as heck towing my 8500# loaded camper, so I'll keep the HD for now. Plus I just put $2500 worth of wheels and tires on it, so there's that too LOL:)
 

·
Registered
Joined
·
103 Posts
hi, mine is a power wagon as well. I have around 25000 miles right now. I still have 17 months left on my lease . What do you think of the gearing on the truck ? seems that the ratios of the trans are really out of sync with the engine power band. I see you have a pedal commander , is yours the bluetooth or standard? I have the standard one and since the end of February has caused a problem with throttle with code p2138 . Had dealer check truck for any system faults and nothing shows up so after talking with pedal commander they are replacing mine under the 2 year warranty.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
hi, mine is a power wagon as well. I have around 25000 miles right now. I still have 17 months left on my lease . What do you think of the gearing on the truck ? seems that the ratios of the trans are really out of sync with the engine power band. I see you have a pedal commander , is yours the bluetooth or standard? I have the standard one and since the end of February has caused a problem with throttle with code p2138 . Had dealer check truck for any system faults and nothing shows up so after talking with pedal commander they are replacing mine under the 2 year warranty.
The 3.73 truck I test drove was sluggish, which is why I insisted on a 4.10 (mine isn't a PW, but has the 6.4 w/ 4.10). The transmission gear ratios are NOT ideally spaced for the 6.4 motor, some of the ratios are a little bit wonky. Online, found an article that says the 66RFE is a hybrid of 68RFE internals (including the gearset) packaged in a 545RFE case. Interesting.

My Pedal Commander is the BT version but I don't use that functionality. It DOES freak out if I use a 2-way radio (amateur band) in the truck, and throws a Throttle Code.
 
1 - 6 of 6 Posts
Top