DODGE RAM FORUM banner

1 - 9 of 9 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Just picked up a 24' StarCraft travel trailer and have a 2010 1500 with the dual 4 pin / 7 pin wiring. The trailer plug won't go in far enough for the cover of the socket to latch the plug in. Its far enough in so everything works but I'm afraid it will fall out.


I can't see anything but it's definitely hitting a hard stop. Ideas?
 

·
Registered
Joined
·
1,305 Posts
I just went out and checked my 7 pin plug on the new travel trailer and the plug goes all the way into the truck socket far enough to latch the plug with the cover. How short is it from locking onto the socket cover?
 

·
Super Moderator
Joined
·
34,750 Posts
I keep my trailer harness receptacles plugged with dielectric grease and haven't had any issues getting 4 or 7 pins hooked up
 

·
Registered
2015 RAM 1500 SLT 4x4
Joined
·
801 Posts
I'll check mine today ! But I would get some electric contact cleaner and try and flush the socket out, road crap gets everywhere ! And like mentioned pick up a small tube of Dielectric grease and lightly coast the pins. Should help. and update us on what you find
 

·
Registered
Joined
·
54 Posts
Just picked up a 24' StarCraft travel trailer and have a 2010 1500 with the dual 4 pin / 7 pin wiring. The trailer plug won't go in far enough for the cover of the socket to latch the plug in. Its far enough in so everything works but I'm afraid it will fall out.


I can't see anything but it's definitely hitting a hard stop. Ideas?
I haven't really investigated yet but seems mine doesn't go in smooth and come to a definitely stop. Seems little spongy and i have to wiggle it good bit to get it to the point where the cover latches. It was enough of an issue for me to unplug look at the mating areas good and try again. I will look at it closer the next time i connect my camper. Never had an issue with all the lights working though.
 

·
Registered
2015 RAM 1500 SLT 4x4
Joined
·
801 Posts
Just checked my 7 and 4 prong hook up. Very smooth, but I did add a little Dielectric grease to !
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #7 ·
I went to a trailer dealer and bought a new plug. It fit just fine and felt more positive going in. I bet I had some junk inside the plug.
 

·
Registered
2015 RAM 1500 SLT 4x4
Joined
·
801 Posts
I went to a trailer dealer and bought a new plug. It fit just fine and felt more positive going in. I bet I had some junk inside the plug.
Bill Thanks for the update,, If you add a tiny bit of Dieletric grease to all the pins it will help with corrosion as well
 
1 - 9 of 9 Posts
Top