DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I thought I would relate my recent success (or appearance thereof) in fixing this sound issue with my 2012 Ram 2500. My radio had been intermittently experiencing no sound when first started. Everything else worked great, but no sound. When the sound did work, occasionally the FM/AM would not have sound, but the satellite radio did. I tried everything. Called the Ram Owner's hotline at MOPAR and tried soft reset as well as the old fuse pull a few times. No Joy. I continued to lose sound intermittently at start. I had firmware version 2.116. I read about 2.126, but the MOPAR people said my truck did not "qualify" for an upgrade. It seems as though this 2.126 is the most recent firmware for the RHR. Well, thanks to the internet I found an .iso file for the upgrade. Burned it to a disk and voila! So far three days in and sounds great. I have read post after post regarding this problem. People returning to the stumped dealers and even replacing radios to no avail. I always kinda figured it was a software thing and it may not work tomorrow, but for now it seems the new upgrade was the fix. The point of this post is for others who are searching for the solution to this problem. Hopefully it is really fixed.:smiley_thumbs_up:
 

·
Premium Member
Joined
·
32,734 Posts
I hope it fixed it for you too
Our Resident Radio GURU, likely had answered questions about this in another post
I just don't remember which post & i have not tried to use the Search function on here lately
 

·
Registered
Joined
·
295 Posts
It appears thats a great update for rhr radios, i just read another thread about it fixng a imtermittdent display issue.
 
1 - 3 of 3 Posts
Top