DODGE RAM FORUM banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 98 Ram 1500 4x4 with a 5.2 ... Problem I am having and hasnt seemed to got fixed by a few shops is this .... it will start and drive fine and then out of the blue it starts pushing way to much fuel ... I get a lose of power and black smoke out of the pipe ... have put over 3000 into fixing up things on this truck and would really like to drive it but with this fuel problem I can go somewhere and if it runs well burn say a 1/4 tank and on the way back if it starts doing that fuel problem it will burn twice as much. Any Idea what causes this :4-dontknow:
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
had a few sensors replaced ... they called them O2 sensors on the exhaust ... dont remember anything about that gasket I can look up some more info on that. Life sure was easier with a carb :)
 

·
Registered
Joined
·
2,050 Posts
Look up threads on the hughes plenum repair and also have the garage do a quick cat check to see if it is operating properly.
 

·
Banned
Joined
·
7,866 Posts
Usually black smoke is hydrocarbon (unburned fuel) You can pull the plugs clean and re-gap em.

Make a note of the worst one and check the injector in that cyl. If it's open and just dumping fuel the truck won't have time to burn it in that cyl.

This is something you can do without spending too much money. I'm not suggesting you do anything different to what is stated above because they could all be the problem or a contributing factor.

Keep us updated on the progress and if you do resolve it please post your resolution.
 
1 - 5 of 5 Posts
Top