DODGE RAM FORUM banner

1 - 2 of 2 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
‘14 Ram, std a/c (no dual zone). Cools fine, then blows warm air a while, then back to cool again. Seems no predictable occasion or length of time when it goes out. Blows fine all the time. Just seems like someone has turned the compressor off. Recirculation on or off makes no difference. Had a buddy check the Freon, and also ‘sniff’ for leaks with a detector. Nothing found amiss. Just curious as to whether someone else has seen this problem, and what their fix was. Methinks it’s something electrical. Like a bad temperature sensor. ??? Thx in advance for all responses
 

·
Registered
Joined
·
47 Posts
Just got mine out of the shop- $1200 for parts and labor, they said it was the A/C condenser which went bad. Truck is less than 3 years old but it has 55K miles on it, so the warrantee was expired. I didn't not have the time to troubleshoot this, and summer is here, so I had to bite the bullet.
Your issue sounds similar to what I had going on in my '90 GMC 20 years ago. The system was low on freon so it would cool great for a while then the system would "freeze up". When that happened I would shut the AC off for maybe 10 minutes or so. I would turn it back on and it would then work for about a half hour. I never did fix it properly I just topped it off with more freon on occasion which worked good enough to get me into my next truck.
After re-reading your post you may want to have someone check the pressure switch, maybe even by-pass it for a bit just to see if it gets rid of your intermittent cooling then not cooling.
 
1 - 2 of 2 Posts
Top