DODGE RAM FORUM banner
1 - 2 of 2 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
So I finally got around to putting a Procharger on my truck, and I have a few minor issues. Nothing too serious, more on the side of annoying and inconvenient. First, vehicle details: 2015 Ram 1500 Sport 4x4, 5.7 Hemi, 3.92 rear end, Procharger is a full system with the D1SC head unit.

The first problem is the transmission tuning. I had previously gotten a transmission tune (combined with a 93 octane tune) from Hemifever, and for whatever reason it doesn't seem to want to shift under full throttle. The gears stick as if I'm in automanual mode and I forgot to shift. However, in the "Perf Trans Tune" that came on the i2 tuner, it shifts just fine, just a little slow. Would getting another transmission tune from Hemifever fix this?

The second problem is the grille shutters. Following the instructions, I removed the grille shutters and grille shutter motor and mounted it under the intercooler, out of the way. It's plugged in and the fuse is good, but I'm still getting a P1D73 code, and it keeps coming back no matter how many times I clear it. Normally I wouldn't mind, but it's preventing my remote start from staying on, and it's getting hotter outside. Has anyone else had this problem and/or found an alternative solution?

Has anyone run into these problems post supercharging, or at all?
 

·
Registered
Joined
·
333 Posts
I installed one on my 2014 last September and have not had any of the issues that you are encountering. I did not buy the complete kit because I already had a Diablo T-1000 tuner. I emailed Sean from hemifever before I installed the procharger to see if it was something he could write a tune for and he said yes. I would reach out to him. He has always been good with answering any of my questions.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top