DODGE RAM FORUM banner
1 - 20 of 24 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 · (Edited)
I have a ABS, Brake Warning and Check Engine light that are all coming on. I am not sure what it is but The ABS and Brake light come on when I start the Truck. They then dim but stay on. I recently got the check engine light on. The ABS and Brake light will go out completely and then come back on. The guy i bought it from told me that it only does it when the weather is hot. I have only had the truck for about 5 days. I was wondering if it could be the rear ABS Vehicle speed sensor. Any trouble shooting would be helpful. Also anyone recommend shocks. I think my origanal Factory shock are probably done.

Thanks,
Nash
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #2 ·
Nobody has anything for me. Man I am racking my brain and wrenches and cant figure anything out. I am waiting on the Rear VSS to see if that might be it.

Thanks,
Nash
 

·
Registered
Joined
·
8,602 Posts
did you check the fuses? if there are any LOL
 

·
Registered
Joined
·
11,547 Posts
Nash, I feel so bad. I won't lie....I could only take guesses. I don't know if your truck has the "3 turn key dance" that many refer to. It will display the codes. Then if you bring the codes to us, we can assess what each code means. Hang tight and we'll see if we can get someone to jump on this!
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #5 ·
Thanks all. Yeah i have checked the Fuses and relays (does not seem to be any relays though). Fluid levels are good. I have just read about the 3 lights then it goes to the speedomoter and odometer not working. But it all leads back to the ABS VSS on the rear Diff. Hopefully replacing this will fix it we will see in a couple of days.

NashDaddy
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #8 ·
No I have not pulled any codes. I took it to a brake shop about a week ago. They were telling me they could not read any codes at all. The guy I bought it from took it to the dealership and head it checked out and the dealership could not figure out what it wrong with it. I am not sure but I dont like all those lights on even though the Check Engine, Brake and ABS light have been off for almost 24 hours.

Nash
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #10 · (Edited)
I took it to Precision tune and they could not even read any codes. I am going to take it to a dealership and let them read it. Hopefully that will work. By the way my ABS and Brake warning light are back on but dimmed. The check engine light is still off and holding for now.
 

·
Registered
Joined
·
10 Posts
Dude its your speed sensor..... its located on the top of the rear diff towards the front of the truck. Oriellys has them for like 30 bucks bro. Do this bud, turn your ignition on but dont crank the truck in this pattern... on, off, on, off, on with in 5 seconds and the odometer will show the trouble code. If its p0500 its the speed sensor. One bolt and unplug the old one, plug up the new on and bolt it down. 30 bucks and 15 min thats it. and to get rid of the engine light disconnecst the positive terminal on the battery and turn the ignition on then off and hook the battery back up. Youre good to go bro.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #12 ·
I just replaced that speed sensor and it was 55 at advanced. LOL I dont have Orielly's here in VA that i know of. I just tried the on off on off. All that happened was the check engine light flashed at me about 10 times. I think it might be the wiring harness to the speed sensor. I hooked it um to a mulit meter and it was giving me about 35 ohms back. I think it is supposed to be between 3-5. Again just scrating my head over this crap. hahaha
 

·
Registered
Joined
·
45 Posts
I had a similair issue with my dash lights coming on, although my turn signals and headlights also didnt work. The problem surprisingly was my key when I turned the ignition it felt real tight. Flipped the key over and the dash lights went out and my headlights and signals worked. Dunno if this is your problem but, it is worth a try since your porblem seems a lil intermittent. Good LUCK!!
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #14 ·
I am really confused because the lights are out but as soon as the weather is above about 75 the lights come back on. I am also being told that it might be the VSS on the hub. Any more ideas.......?????
 

·
Registered
Joined
·
203 Posts
Had problems with my ABS and check engine light coming on turned out to be the brake lite switch, check that. Mine was out of adjustment.
 

·
Registered
Joined
·
1 Posts
I'm new here and I'm having an ABS issue. My brother and I just changed the pads on the front last night, now he has no preassure, and the light is on. We drained the lines, refilled/bled them and re connected, any ideas on what it might be?
 

·
Registered
Joined
·
1,640 Posts
I'm new here and I'm having an ABS issue. My brother and I just changed the pads on the front last night, now he has no preassure, and the light is on. We drained the lines, refilled/bled them and re connected, any ideas on what it might be?

You have speed sensors on the hubs that if they are failing can cause an ABS light to come on. Your speed sensor is likely where mine is on the front hub and it is behind the rotor on the front top side of the hub. On my 07, I just bought the ABS speed sensor that goes on the rear axle because my ABS and brake light was coning on intermittently, and it solved the problem. Hope this helped a little but it may be different for your truck. Maybe Randy will chime in and add some light if I am off base here.
 

·
Registered
Joined
·
203 Posts
Not sure what you mean by the re connected? Did you check to make sure the pistons in the calipers did stick when forced them in to replace the pads.
 

·
Registered
Joined
·
21,490 Posts
I'm new here and I'm having an ABS issue. My brother and I just changed the pads on the front last night, now he has no preassure, and the light is on. We drained the lines, refilled/bled them and re connected, any ideas on what it might be?
I would recommend to ya to start a new thread on your problem . It will get more exposure . Might want to stop by the newbie section and introduce yourself also .
 

·
Registered
Joined
·
1 Posts
I also had the abs, and brake light with the spedometer and odometer non functioning. I replaced the abs speed sensor in the differential and fixed each problem. The one I took out would not rotate.
 
1 - 20 of 24 Posts
Top