DODGE RAM FORUM banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
PLEASE HELP Can anyone tell me the symtoms of a dead ambient air temperature sensor has on a ram 1500 95 5.9L. OR What would cause starting problems as in sometimes it will start. sometimes it kills my battery but will start with boost, and sometimes it won't start, even with a boost. All within a 8-9 day period. But when it does start, or I force it to start with boosting it will run fine . Trip all over town with no decernable hesitations. If a fuel pump is shoot. Can it still operate intermitantly?
 

·
Registered
Joined
·
1,280 Posts
A fuel pump can act interment as it goes out. An ambient air temp will cause it not to want to idle or idle up when cold. If your in doubt on fuel pump there is a test port on driver side of fuel rail. You should hold 45 lb. at all rpm's.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks man. I'm changing pump now, just came in to file sharp edges off socket I ground a slot in to try and make a strap wrench. That thing is on there tight. I've made marks to align newpump so fuel guage will work(hopefully). Bettween monies at moment so no cash for presure gauge or even shop time to test pump. I bought used pump from dead truck with 240000KM but pump is Airtex(which I know to be aftermarket) and clean so I think it was fairly new to the wreck. At first i thought it may just be battery, but at times it wouldn't start even with boost from bigger unit. I'm no mechanic (carpenter) so been to cypher problem is trying my paitence. Luckily my reno job is 5min walk from home, and but 2 weeks from completion(cash) so if this is not solution. I'll bring to shop then. Work is 5 min away. Groceris and tim hortens is 30min away lol. So I will try this. Thanks man
Steve
Edson Alberta
 
1 - 3 of 3 Posts
Top