DODGE RAM FORUM banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have AMP power step installed on my 2010 3500 Crew Cab Ram/Dually I had those power step installed the year 2010 and those fastener that came with it has torn out under the mounting site. AMP fastener was not made to provide good fasten to the body of the truck. I had to remove the driver's side since the holes were cracking open due to the small fastener (poor design) Any of those have gone through the same issue. This is a costly repair and restructures the underbody to restore it. I believe AMP liable for this costly repair. Thank goodness I did not fall when the step was not working properly.
 

·
Registered
Joined
·
338 Posts
Not unique to your amp power steps. I know of trucks with the stock oem step bars that had that same cracking going on. One guy I know had to take one step bar off because he was afraid it was going to fall off.
He decided to put the Amp steps on. Amp sells reinforcement plates that I welded on his truck. Then we mounted the new Amp boards using new rivnuts. Plus there was bolts that went through the pinch weld. Plus after mounting the new brackets under the truck, you actually drill a hole and install a pop rivet at all four locations. Was there bolts through the pinch weld and pop rivets installed?
 

·
Registered
Joined
·
308 Posts
Who installed them? Did they use the backing plate that is required or did they just put the rivnuts in without them? (sure sounds like they were not installed)

.
It seems this is what happened to the truck my buddy is looking at. Its a 2012 3500 CC with Amp steps with the same cracking around the fastener. We'll just finish installing the suspension from 4Wheelonline on the Wrangler and we're going to take a closer look. It sounds the reinforcement plates for the steps were not installed.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top