DODGE RAM FORUM banner
1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
After 2 months, my OEM Sirius radio is constantly showing "acquiring signal". Its not an activation issue and every once in a blue moon it will lock for a few minutes. Has anyone had issues with the stock radio in this regard or for that matter the SAT antenna on the vehicle roof?
 

·
Registered
Joined
·
471 Posts
try and see if this happens in the same place on the road every time. i know one area where i drive home from work and one on way to work where ill lose a signal due to heavy tree growth over the road,same place all the time. thats the only time i get that and my radio has never locked although i do get a subscription update from time to time where the radio just stops till it updates. (about 10 seconds if that)
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
Sirius

try and see if this happens in the same place on the road every time. i know one area where i drive home from work and one on way to work where ill lose a signal due to heavy tree growth over the road,same place all the time. thats the only time i get that and my radio has never locked although i do get a subscription update from time to time where the radio just stops till it updates. (about 10 seconds if that)
No unfortunately it is basically always in that state. Location has no bearing. It worked fine for the first 2 months I have had the truck and now this. I believe I either habve a bad tuner or antenna at this point. Likely going to need to bring it in for service.
 
1 - 4 of 4 Posts
Top