DODGE RAM FORUM banner
1 - 8 of 8 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter · #1 ·
so I had HID's in my truck and lost the light on drivers side several times brought it to the dealer after i disconnected everything and they said the TIPM was gone so I had it replaced and this happened 2 times and this time i lost my lights again on the same side but this time i told em to find the prob and it was a loose pin inside the wiring harness the main one so they replaced it so my question is has anyone lost a TIPM due to HIDs I want to put mine back in is it safe? was the TIPM ever gone or was it just that harness? what do you guys think, is it safe to put HID's back in my truck its a 2010 dodge ram laramie quad headlamp only want to do low and fogs like before
 

·
Banned
Joined
·
1,657 Posts
No it's not safe to put the HID's back in. You most likely have no projectors and are blinding every oncoming car with your plug and play HID lows and fogs. Please think of others and don't put those back in. All they do is blind ppl due to glare.

Thanks
 

·
Registered
Joined
·
12,860 Posts
Being as it was a faulty pin in the harness that caused the issue, you should be safe running HID's again. There are a bunch of us 4th gen guys running HID's without issue.
 

·
Registered
Joined
·
157 Posts
Discussion Starter · #4 ·
cbrambo497 I do have projectors, do you think your the only one with projectors I read your comments on other peoples post all you do is criticize HID's that people have "o I have projectors and its ok" blah blah blah" who cares, I would put hid's on my truck in a million places just to piss you off, you didn't even answer anything about the question I had which is what this site is for so take your opinions and stick em!!!
 

·
Registered
Joined
·
1 Posts
I actually have that same problem now, my low or high beams don't work on the right side. I tried switching ballasts and blubs nothing. Changed relay harness for my HIDS and resistors nothing, tried changing the plug and nothing. What I am lost at is the plug is still getting power to it. Do you by any chance now where this loose pin was on your truck so I can try and do that before I end up paying for a new TIPM?
 
1 - 8 of 8 Posts
Top