DODGE RAM FORUM banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
heater not blowing hot at all! i have a leaking waterpump that seems to be leaking out of the weep hole, any ideas where i should start to try and fix this?? any advice would be greatly appreciated!! thanks!
 

·
Banned
Joined
·
7,866 Posts
1.) Was the heat working before the pump started leaking?

2.) "Heater not blowing hot at all" Can I assume the fan is working?

3.) Is it exchanging between defrost, vent, floor, etc...?
 
G

·
Agreed ^^^^ If it was working before, then the coolant issue and the heater core need to be looked at.

If the HVAC functions of defrost, vent, heat, floor, mix don't work, then it's the HVAC blend door, which is a common issue.
 

·
Registered
Joined
·
116 Posts
Not sure if this is the issue but I had a thermostat stick wide open before which killed just about all the heat I was getting.
 

·
Banned
Joined
·
7,866 Posts
Agreed ^^^^ If it was working before, then the coolant issue and the heater core need to be looked at.

If the HVAC functions of defrost, vent, heat, floor, mix don't work, then it's the HVAC blend door, which is a common issue.
The thermal relay on the passenger's side floor board up under the glove box-towards the center is another thing worth checking in the hopes of not having to do the blend door which as MD said is a common cause.

I'd turn wrenches on the water pump to repair the obvious problem and see if a proper coolant level alleviates the problem...if not you've got a couple of good leads to follow.

By the way... The fan is threaded to the water pump. Pull one of the 13mm bolts on the pulley behind it and stick a screw-driver in the hole to keep it from spinning when you turn the large nut COUNTER-CLOCKWISE. (That was a preemptive post)
 

·
Registered
Joined
·
47 Posts
I agree that the first order of business would be to replace the water pump. The heater core on our trucks sits higher than the rest of the cooling system and if you're leaking coolant, your heat is going to suffer. As you know, water pump leaks only get worse, and you already know that if the coolant level gets way too low, having no heat in the cabin will be the least of your worries.

What readings are you getting from your temperature gauge? It would be interesting to know if the cabin heat is poor even when the temperature gauge is pointing to the 200 degree range.

Some steps to try:
1) make sure the coolant level is full
2) "burp" the cooling system to make sure there's no air in it
3) take a ride and see if the heat works - if it does, your lack of heat was strictly due to a low coolant level; but if still no heat and if your temperature gauge indicates your thermostat is operating correctly, you may be looking at a heater core problem -- but I would still replace the water pump first.

Just last weekend, I replaced the heater core in our '96 Ram. I had replaced the water pump in August, and the thermostat in September, and then after cold weather arrived we found that the heater's output was inadequate. When flushing the heater core I could tell it was a little plugged up, and after replacing it, the heat was nice and hot. So it seems that even a slight restriction in the heater core will inhibit coolant flow enough to keep the heater core from getting sufficiently hot. My guess is that coolant leaking out the weep hole reduces pressure in the system and that would seem to reduce the volume of hot coolant passing through your heater core. I'm not certain of this though and am tossing it out there for discussion.
 
1 - 7 of 7 Posts
Top