DODGE RAM FORUM banner
1 - 20 of 32 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
so we removed the running boards and finally ordered the drop kit. the back was really easy to install, about to try the front now that its daylight again. had to drive it today being the only vehicle we have and the wife was not happy with gas milage dropping to 10 mpgs...is it going to balance back out with the front dropped, i cant think of why it would change 5mpg for lowering it, i could for raising. maybe im just missing something. ill check back shortly when i get things done. thanks for the help guys, sorry too lazy for pics while working, ill take some after the fact
 

·
Registered
Joined
·
17,710 Posts
If you are going by the evic then don't pay attention to the mpg readings. Dropping the vehicle won't cause a drop in the mpg. If you are worried about it that much, just reset the adaptives by pulling the fuse our by disconnecting the battery for 15 min.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
after finishing install, reset computer and was able to reset evic to 15.3, prolly best ive gotten outta of it and wife is very happy with it and the way it looks

side note, anyone need stock shocks, coils, or chrome running boards for 2011 quad cab big horn???
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
Now pondering if i screwed something up bc we took it in for the alignment and theyre telling me im gonna have to cut tie rod ends, fml. Looks like im taking it to the truck outfitters shop and get their opinion
 

·
Registered
Joined
·
3,666 Posts
U shouldn't have to cut any of the the tie rod ends, i would take it to another shop cuz something doesn't sound right!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
thats what i was figuring, i believe ive saved everything and will be contacting beltech asap to see what they say and think about the whole situation?
 

·
Registered
Joined
·
571 Posts
Keeps us posted. I have the belltech kit in the garage with the sp shocks. I am planning on installing this Saturday.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
well ive taken it to the sport truck place in town that does lifts and drops all day, they agreed that dodge has to make new control arms or i just have to rotate tires and buy new ones as needed...guess who gets to remove said kit this weekend as now the passenger tire is rubbing now. took it back into the same place and now the spring has turned off and is slightly out of the cup and so that screws more things up. my problem now is that the kit has you cut the front bumpstops so they might not be gettin those back???

anyone with any help would be greatly appreciated prior to me wasting a weekend on removing this kit. ive seen numerous people with them installed on 4th gens and even on 2011 quad cabs, i cant be the only one thats screwed up???
 

·
Registered
Joined
·
3,100 Posts
That doesnt sound right at all... Sounds like a bad install and they are trying to cover their tracks blaming dodge/the kit.


See if there is anyone around you in the regional section that has done the install and could maybe come spend a few hours looking it over/redoing it with you trying to get it right.


I wish you were closer. I took my running boards off cuz i initially didnt like them and want the back now lol
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #11 ·
well i supervised the guy that did it, told him exactly what to do at every given second, took him like 5 hours on the rear one night and 5-6 hours on the front the next night. im confident that i read the instructions to him word for word and i know he listened, as if you couldnt tell, i was the mechanic that did the install. i have done other drop kits on cars and being my wifes truck i was in no hurry and took my time. i just spent an additional 20 minutes laying under it comparing things. on the ground, passenger bump stop is on the lower a arm, and drivers is a lil ways off. when it started rubbing, the shop said that the springs werent lined up, the end of the spring sits right in the cup the exact way it fits, tomorrow im hoping to get it in the air and tire off so i can recheck everything yet again, otherwise its coming off this weekend and jegs is gettin it back.

on a side note, i still have the running boards in storage, not sure if the wife is gonna want them back on or not, origional idea was to put them on here, craigslist and or ebay.
 

·
Registered
Joined
·
3,100 Posts
shipping those is a royal pain in the butt.

You might want to take them off and measure the spring rate (lb wise) and call belltech and see what they say. IDK if jegs is gonna take it back even with it being faulty.

10 hours total isntall time seems a little much, even with beer/smoke brakes it only took us 5 1/2 hours total to do one locally with 2 guys and hand tools
 

·
Registered
Joined
·
571 Posts
yea i curious to find out what happened, I just put the kit on this past saturday, it took me 5 hrs by my self including a trip to the auto parts store for a wrench so i could get the rear shocks off. three days of driving and still no problems.
 

·
Registered
Joined
·
101 Posts
Call me crazy, but are you sure you got the right kit?

I've got the Belltech 2-4 w/ the SP shocks and it aligned perfectly at my Dodge dealership.

If I remember right, there were some people that had issues of getting a 2WD kit when they had a 4WD truck and vice versa. I'd look at it just to make sure.

just my .02
 

·
Registered
Joined
·
3,100 Posts
Call me crazy, but are you sure you got the right kit?

I've got the Belltech 2-4 w/ the SP shocks and it aligned perfectly at my Dodge dealership.

If I remember right, there were some people that had issues of getting a 2WD kit when they had a 4WD truck and vice versa. I'd look at it just to make sure.

just my .02
belltech doesnt make a 4wd kit. The 2wd guys are just using the 2wd kit.


I can see maybe getting the kit for the RC and having a QC/CC and maybe that messing thing up though
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #16 ·
called beltech today after work. they say they are waiting on test vehicles to start R&D on 2011-2012 model rams. the 963SP is not going to fit the 11 or 12s due to dodge changing the dimensions of things. i asked what i do with the 963sp kit i have, and they said call the ppl i ordered it from...called jegs and let them know what beltech said and jegs is changing their website not to have 2011 listed anymore and emailed me the links to return my kit and are paying for return shipping.

now i just have to find a kit that works correctly........
 

·
Registered
Joined
·
3,973 Posts
Uuuhm I just put the 963SP on my 2011 Ram CC and it works perfectly, had Dodge align it today amd there's no problems with it, only think you have to deal with is about -.5 Camber on the fronts which isn't a big deal if you rotate the tires. Not sure what happened on your install bud but You may have been given the wrong springs on accident. Not to jack your thread but I'll include a couple picks and a link to the install just to see if you missed something by accident. And in all honesty I left the front bump stops in because I haven't even hit them going over a speed bump or anything. That may change with the more miles I put on the suspension but for now the stockers are in place.

Link: http://www.ramforumz.com/showthread.php?t=107010
 

Attachments

·
Registered
Joined
·
22 Posts
Discussion Starter · #18 ·
well after working on it too many times not to be happy with it, full kit is installed and meausements are going to be take on a flat surface today after work. i just left the shop that was doing the work. the first spacer that they installed was actually the lower eyelet on the right front, says it was split in half and allowing the shock to move and rattle. now he says that the only thing left that it could be is a blown shock which couldve also damaged the spring. one more time of laying under truck today to remove suspected damaged shock and then i dunno wth ima do...may have to switch them from right side to left side and see if it switches ride height
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #20 ·
well not to bring it back up but from what i can tell, everything is fixed. jegs sent a second kit and is paying for return shipping. the spring was noticable smaller, though stamped same part number. ive seen no rubbing nor have i heard it since last wkend when i redid the kit. there is actually space betwixed the bumpstop and the lower control arm, everyone happy with it and now onto other projects :)
 
1 - 20 of 32 Posts
Top