DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Ok kinda have a problem here I just replaced my front shocks and sway bar bushings, and now when I hit a pot hole,rail road tracks, I have a for a lack of a better term bang coming from my driver side front tire hit the same holes with the passenger side and its nice and smooth.

So I just went ahead and replaced the shock thought maybe a bad shock not the case still there could it be from the sway bar? Did I install it wrong


Using skyjacker shocks need help, Any info would help.
2005 ram 1500 4x4 5.7L
 

·
Registered
Joined
·
5,887 Posts
I know a few guys one here when installing the bislteins, mixed up the order of the washer/nut/and somethin else and it caused this. Double check your install very carefully
 

·
Registered
Joined
·
31 Posts
I know a few guys one here when installing the bislteins, mixed up the order of the washer/nut/and somethin else and it caused this. Double check your install very carefully
:iagree:My best friend did this exact thing in a Jeep. It's easy to mix up the order, especially if you're working on it late or are tired.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks guys it was a late night,I have the week end off and will be looking into this issue, will let you know how it goes
 

·
Registered
Joined
·
141 Posts
I installed my leveling kit last weekend and couldn't get the rubber bushing between the washer and control arm back on so I went for a ride to get it to settle and had similar sounds coming from the front end. When I go home I was able to put everything back like it was supposed to be and the noise was gone.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
The sleeve that goes into the bottom bushing was abnormal replaced with one from a mother shock and every thing looks good.
 
1 - 6 of 6 Posts
Top