DODGE RAM FORUM banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I'm getting Bilstein 5100's installed on my 2011 Ram 1500 Sport today at my local shop. They just called me and told me now that they have my old struts out they need spring seats for the new struts. I told them that the 5100's were supposed to reuse the OEM ones. They are saying that the struts are "gas charged and we aren't comfortable cutting them."

Did anyone else have to cut there stock struts or how did you get your stock spring seats off the stock springs?

Any ideas what I should tell them? (Other than, put my truck back together and I'll find someone who knows what they are doing?)

Thanks in advance!
 

·
Registered
Joined
·
1,667 Posts
The caps off the end of the strut come right off and the strut remains intact. They should have no problem just using a hammer to remove the caps.
 

·
Registered
Joined
·
294 Posts
my local dodge dealer didnt know what to do with the 5100's either so i took them to ford they had em done in 20 min i did my own install aside from that
 

·
Registered
Joined
·
82 Posts
I gave mine a couple wacks with a hammer and they came right off!!! Its not hard at all>
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6 (Edited)
Thanks for the tips.

The shop didn't want anything to do with the job. They put the truck back together and told me to come pick it up. They charged me for an hour of labor ($70) and told me they wouldn't touch the stock struts. They were trying to tell me that something was welded on to prevent it from coming off. I pointed out that the directions from Bilstein say to remove the OEM and re-use it but it fell on deaf ears. Next I called my dealer and they wanted $497 + tax to install 5100's on just the front. I pointed out that I had them in my hands and just needed them installed and he said that he figured that. He told me 3 hours per side.

So, I'm going to tackle it myself tomorrow. I plan to follow the directions other users
have posted in the past as well as the directions from Bilstein and knock this job out. I look forward to taking pride in knowing that I completed this job.

Also, I appreciate any tips you have for the installation.
 

·
Registered
Joined
·
136 Posts
I would go ask for your money back. They agreed to do a job and did nothing but take your money.

The install is pretty straight forward. I actually just did mine just this morning in 2 hours. A spring compressor is a flat out have to have item for the install.
 

·
Registered
Joined
·
312 Posts
Patience!!! The lower strut bolt causes issues with some...I took the nut off and then hit it out with a screwdriver on the bolt...depending on where u are setting them will depend on how hard it is to reinstall...I had mine at 2.75 and took some time getting the lower part of shock to clear the control arm...I don't weigh much so getting enough muscle to push the control arm down enough to clear was my biggest issue...I finally rigged the stock jack in there to push it down far enough...******* ingenuity I guess...GOOD LUCK!!! Not a difficult job overall tho
 

·
Registered
Joined
·
82 Posts
jeeze are there real"shops" around anymore? How is it that people like us can do simple mods but "pro"at a dealership or shop cant figure it out? LOL it is funny to me . Just like my radio issue with the cluster lights i figured the problem out in 5 min on line but took them two weeks to do the same?
 

·
Registered
Joined
·
161 Posts
Wow, mechanics that obviously don't know what there doing! Like everyone else said, take your time and you should be good. One thing is to make sure you install the washer correctly, it goes on the shaft first, then your spring cap followed by your locknut.

Here's a pic
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
Well crap! I put them in early yesterday afternoon but I incorrectly installed the washer. I put the spring cap on then the washer and nut. I drove about 25 miles last night and didn't notice any issues. Is the washer location critical? I really don't want to take it all apart again but if this will cause problems in the future I'd rather fix it now.
Thanks!
 

·
Registered
Joined
·
161 Posts
Well crap! I put them in early yesterday afternoon but I incorrectly installed the washer. I put the spring cap on then the washer and nut. I drove about 25 miles last night and didn't notice any issues. Is the washer location critical? I really don't want to take it all apart again but if this will cause problems in the future I'd rather fix it now.
Thanks!
Yes it's critical, you can damage your shock, every time you ht a bump your piston rod is going to go through your spring cap. Gonna have to take it apart again.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Finished the job today. I had to completely remove the struts I put in yesterday to move the washer. I had previously installed the washer between the plastic spring cover and the nut. The washer is now under the plastic cover. I'll get some pics up tomorrow. Thanks for your help everyone especially chickenhole!

I'm still considering stopping at the shop tomorrow and asking for my $70 back since the strut cap wasn't welded keeping them from getting the spring seat off.

Now on to my next mod! Any suggestions?
 

·
Registered
Joined
·
161 Posts
Finished the job today. I had to completely remove the struts I put in yesterday to move the washer. I had previously installed the washer between the plastic spring cover and the nut. The washer is now under the plastic cover. I'll get some pics up tomorrow. Thanks for your help everyone especially chickenhole!

I'm still considering stopping at the shop tomorrow and asking for my $70 back since the strut cap wasn't welded keeping them from getting the spring seat off.

Now on to my next mod! Any suggestions?
Glad you got it straighted out, your not the only one that has done that, how do you think I found out ? Lol . You should definitely ask them for your money back, I'm sure they were just making up excuses though not to install, because they didn't want to do something that wasn't oem. Post some pics of your truck!
 
1 - 14 of 14 Posts
Top