DODGE RAM FORUM banner

1 - 11 of 11 Posts

·
Registered
Joined
·
409 Posts
Discussion Starter · #1 ·
Got the light in the truck and installed the BiXenon Harness.

Going by the instructions yielded no low beam and low beam function when high beam turned on.

Swapped out the low and high beam connecters on the ballast and solenoids and it works great with just power.

When I start the truck the low beam works great and when I go to high beams it just starts to flicker and the relay chatters like crazy.

Next issue is the right side isn't a sharp cut-off like the left side. I think I need to maybe adjust the cut-off closer or further away from housing. Not sure if anything else might be causing this.

Any pointers greatly appreciated by someone who has done a few of these.
 

·
Registered
Joined
·
340 Posts
Hmmmm, verify your ground on the relay harness.

mikeski...
 

·
Registered
Joined
·
3,100 Posts
Dodge doesnt send a steady stream of power to power the headlights. Rather stupid short bursts which has been accredited with the "flickerin".

Error cancelation or capacitor light harnesses have shown to greatly reduce the risks of the flickering issues.
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #4 ·
Dodge doesnt send a steady stream of power to power the headlights. Rather stupid short bursts which has been accredited with the "flickerin".

Error cancelation or capacitor light harnesses have shown to greatly reduce the risks of the flickering issues.
Installed capacitors between high beam signal and ground, now the relay cycles twice as fast and you don't notice the light flicker, but can hear the relay humming because it's cycling very fast.

Anyone have luck with installing Bixenon harness?
 

·
Registered
Joined
·
340 Posts
Time to call the supplier.
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #6 · (Edited)
Time to call the supplier.
I did this morning. That's who suggested the capacitors. They said the Rams are vehicle specific and let us know what you do that fixes it. They had no further assistance to offer. Funny how when I ordered the kit, they never mentioned that it isn't working properly on Dodge Rams

The Retrofit Source(TRS).
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #7 ·
Well, got up this morning and fixed my high beam relay hum.. TRS had said yesterday to put a from high beam to ground and what I ended up doing was attaching another CAP at same spot in harness from low beam to ground. So now have CAPS from orange to ground and blue to ground right at the truck headlight input. This smoothed out the cycling DC voltage and stopped the relay from humming. Now I just need to fix the cut-off on the right side and we will be golden. I think that might take some more effort:)
 

·
Registered
Joined
·
3,100 Posts
Are they in stock housings? My cutoffs are very fuzzy and its just because they arent in a projector tye of housing. Not really too much you can do
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #9 ·
Are they in stock housings? My cutoffs are very fuzzy and its just because they arent in a projector tye of housing. Not really too much you can do
Mine are in projectors and super clear lens housings. The one on the left is very crisp and nice purple tint.
 

·
Registered
Joined
·
3,100 Posts
gotcha okay that makes sense then lol
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #11 ·
Cutoff fixed with some hit and miss adjusting with a hooked coat hanger and slight(I mean slight) pulling of the cutoff closer to the housing.
 
1 - 11 of 11 Posts
Top