DODGE RAM FORUM banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2014 Ram 2500 diesel. My abs and traction control lights came on a few weeks ago but went off after a few hours then did the same thing a few days later. Now there staying on and my 4wd is disenabled while there on. My check engine light is on now too with codes p0542 and v010e. Plugged my tuner in yesterday to check codes and after that my speedometer stopped working then my electronic throttle control light came on. And my door locks don’t work right. Almost like there delayed. Anybody have any ideas what’s going on?
 

·
Registered
Joined
·
2,029 Posts
I have a 2014 Ram 2500 diesel. My abs and traction control lights came on a few weeks ago but went off after a few hours then did the same thing a few days later. Now there staying on and my 4wd is disenabled while there on. My check engine light is on now too with codes p0542 and v010e. Plugged my tuner in yesterday to check codes and after that my speedometer stopped working then my electronic throttle control light came on. And my door locks don’t work right. Almost like there delayed. Anybody have any ideas what’s going on?
Hi Rmj1,

We certainly understand why this would be concerning! If you are not able to determine a solution based on suggestions provided here, we kindly recommend following up with your servicing Ram dealer as they are in the best position to provide assistance. If you do work with your dealer, our team is more than happy to provide you with an extra layer of support for that process.

Mark
RamCares
 

·
Registered
Joined
·
2,029 Posts
I have a 2014 Ram 2500 diesel. My abs and traction control lights came on a few weeks ago but went off after a few hours then did the same thing a few days later. Now there staying on and my 4wd is disenabled while there on. My check engine light is on now too with codes p0542 and v010e. Plugged my tuner in yesterday to check codes and after that my speedometer stopped working then my electronic throttle control light came on. And my door locks don’t work right. Almost like there delayed. Anybody have any ideas what’s going on?
Hi Rmj1,

We certainly understand why this would be concerning! If you are not able to determine a solution based on suggestions provided here, we kindly recommend following up with your servicing Ram dealer as they are in the best position to provide assistance. If you do work with your dealer, our team is more than happy to provide you with an extra layer of support for that process.

Mark
RamCares
 

·
Premium Member
Joined
·
32,663 Posts
P0542 Intake Air Heater A Circuit High
 

·
Registered
Joined
·
384 Posts
Low voltage can cause a lot of weird shit to happen(just because it starts doesn't meen the PCM is seeing proper voltage) and bad grounds also.I would try and see what all these problems have in common if you can lay hands on a schematic
 

·
Registered
Joined
·
2,248 Posts
CVX is right, this smells of a battery issue as the first item to test. Monitor the voltage and if you have a meter that can capture minimum and maximum voltages even better. Just because a static measurement shows good voltage doesn't mean a cell in one of the batteries isn't acting up. Recording minimums will detect that. Also, keep in mind the grid heater pulls around 200 amps when it cycles on. If that is dropping the voltage down that could trigger these modules.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Thank you
I had both batteries tested and they tested great. That mean it could still be a battery issue?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
I had both batteries tested and they both tested great so could this still be the issue? Today I had a noise in my front end and i thought it was a brake caliper locking up because it was hot but it ended up being my right front hub bearing assembly went bad. Changed that and my traction control light went off but the other 3 are still on and still no 4wd. Brake pads were pretty wore so changed them 2. Could the abs sensors be what’s causing that light? Can I clear the lights and see what happens?
 

·
Registered
Joined
·
384 Posts
Yes clear the codes and see what happens.Even if you perform a repair it doesn't mean that the lights will go out without clearing them.Bad bearing could have taken out the sensor though
 
1 - 10 of 10 Posts
Top