DODGE RAM FORUM banner

1 - 8 of 8 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
Got in the truck to take the wife around town...Playing taxi driver, but not getting paid:) The truck worked fine yesterday, but when we started out the check engine light came on. I noticed an immediate loss of power, the truck was vibrating and felt like a few cylinders were not firing. I immediately called the dealer and told them what was going on. They told me as long as the check engine light was steady I was ok to drive it to the dealer. I dropped it off Saturday afternoon, they said they would try and get to it on Monday. I will let everyone know what they find.
 

·
Registered
Joined
·
2,576 Posts
ditto
 

·
Registered
Joined
·
114 Posts
Discussion Starter #4
Update, got the truck back on yesterday. They told me it was a loose terminal fitment for an injector. Drove away and the truck started up again...before I could get back to the dealership to show them it stopped. Took it to the dealership anyway. Of course they told me they can't do anything unless I bring it in with the issue so they can see it. Great, now I get to play Russian roulette and hope I don't get stranded somewhere.
 

·
Registered
Joined
·
1,965 Posts
Update, got the truck back on yesterday. They told me it was a loose terminal fitment for an injector. Drove away and the truck started up again...before I could get back to the dealership to show them it stopped. Took it to the dealership anyway. Of course they told me they can't do anything unless I bring it in with the issue so they can see it. Great, now I get to play Russian roulette and hope I don't get stranded somewhere.
Hi JmacBlack,

I sincerely apologize for any frustration associated with your situation. If you end up having to address this with your dealer again, please let us know via private message. We would be more than happy to provide you with an additional layer of support for that process.

Mark
RamCares
 

·
Registered
Joined
·
114 Posts
Discussion Starter #6
Back to the shop again yesterday. Got in the truck and as soon as I fired it up, I could feel the rumble of a cylinder not firing. Took a picture of the dash to capture the time and show the engine light on. I thought it might go out like the last time before I could get to the dealer, but it did not. Maybe the third time is the charm for this issue and they can really fix it.
 

·
Registered
Joined
·
1,965 Posts
Back to the shop again yesterday. Got in the truck and as soon as I fired it up, I could feel the rumble of a cylinder not firing. Took a picture of the dash to capture the time and show the engine light on. I thought it might go out like the last time before I could get to the dealer, but it did not. Maybe the third time is the charm for this issue and they can really fix it.
Hi JmacBlack,

I regret to hear that you are experiencing this concern again. Please know that I would be more than happy to escalate a case on your behalf to connect you with a case specialist for an additional layer of support while you are working with your dealer. Kindly follow up with us via private message to get the process started.

Mark
RamCares
 
1 - 8 of 8 Posts
Top