DODGE RAM FORUM banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,012 Posts
Discussion Starter · #1 ·
Took our first road trip in the RAM this past weekend. It was about a 2 hour drive to the lake and it went well. The only thing I did "out of the norm" was turn on the tow/haul mode when I got into the hilly/twisties, which made it a joy to drive. The next day, the check engine light came on. While the light was on, I noticed that the ECO never came on. After dinner, the light went out and ECO would activate. Then the next day on the drive home that CE light was on for the entire trip and ECO never came on. Obviously theres some connection between the two....but its back to the dealership...AGAIN. :smiledown:

Anyone had this problem pop up?
 

·
Registered
Joined
·
3,373 Posts
On my 2009 when my check engine light popped on because I had a loose gas cap the "Fuel Saver" icon never appeared but I know it will dropped down to 4 Cylinders because I could hear it thanks to my flowmaster exhaust. I don't know why but if the CE is on the computer just does some funny stuff...
 

·
Registered
Joined
·
1,012 Posts
Discussion Starter · #6 ·
I took the truck in. They are replacing the door lock switch and replacing the fuel sending unit....they supossedly replaced that the second time I had it in the shop for the fuel gauge problem. Hopefully three times is a charm. They say that the code that showed up for the check engine light was from the fuel sending unit malfunction. Which kind of makes sense because instead of the fuel gauge just constantly not reading right it was starting to jump around, it would go from full to empty, then back up to half full, then down to empty and back up to a three quarters, etc...so it was really messed up.

Oh well, we'll see.
 

·
Registered
Joined
·
1,168 Posts
I don't get an ECO light in my '09....but like Arth, I don't need a light with my exhaust lol
 
1 - 8 of 8 Posts
Top