DODGE RAM FORUM banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I keep getting a check engine code of P0128, engine low temp. I changed the thermostat, then the temp sensor. The code comes back in about 200-250 miles. I am running the AC most of the time, and the dash screen will show the temp stating between 193 and 220. If I turn the AC off, the temp runs between 203 and 230. I have not cleared the CEL and run with AC off for a few hundred miles because the wife and I like to be comfortable. I will have to bite the bullet and try that, soon.
Any further options or thoughts would be appreciated
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Got the latest computer recall update. Supposed to cure the ECU from holding old codes and failing inspection. This code has not come back since. I'll wait for next summer, when I'm running the AC a lot to see if it comes back.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Got the latest computer recall update. Supposed to cure the ECU from holding old codes and failing inspection. This code has not come back since. I'll wait for next summer, when I'm running the AC a lot to see if it comes back.
It's Ba-ack, the code CEL coming on are back.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Thanks
Having already gone with new sender and thermostat, I had my antifreeze flushed and new put in. It has been 3 weeks so far, hoping for a lot longer.
Sell, now I learned that there is a bleeder valve on the top of the thermostat. we got quite a bit of air out. Now my heat is steady, before this I would get cool drafts through the heater at highway speed. Apparently, this was air bubbles that would not self bleed.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Sell, now I learned that there is a bleeder valve on the top of the thermostat. we got quite a bit of air out. Now my heat is steady, before this I would get cool drafts through the heater at highway speed. Apparently, this was air bubbles that would not self bleed.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
I had to take it in for a recall again. I had them look at the CEL P0128. They said thermostat. The new one I put in last year was running 190-200. The new one the dealer put in Thursday is running 214+ opening at about 222. Maybe that is the problem.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
I had to take it in for a recall again. I had them look at the CEL P0128. They said thermostat. The new one I put in last year was running 190-200. The new one the dealer put in Thursday is running 214+ opening at about 222. Maybe that is the problem.
I think it might be fixed, $396 for diagnostic and new thermostat (thermostat $185). over 60 days and no CEL, keeping my fingers crossed.
 
1 - 9 of 9 Posts
Top