DODGE RAM FORUM banner

1 - 20 of 21 Posts

·
Registered
Joined
·
13,690 Posts
Discussion Starter · #1 ·
...for running a 14.99 in the 1/4 last night with just a few bolt ons in his 287cid equipped ram :) :smileup:. Not bad! I have basically the same mods and I'm running high 15's...
 

·
Registered
Joined
·
507 Posts
Hey thanks Sean! That time can be improved for sure!
 

·
Registered
Joined
·
507 Posts
Yes, should be posting some pics and vids tomorrow morning!:wavey:
 

·
Registered
Joined
·
507 Posts

·
Registered
Joined
·
13,690 Posts
Discussion Starter · #6 ·
Cool man, truck looks good. Get another converter in there and run even faster :).
 

·
Registered
Joined
·
507 Posts
nice run man...breakin a milestone barrier is always a great accomplishment!!
Heck ya I was stoked:) hopefully 14.5 will be in my reach soon
 

·
Registered
Joined
·
6,250 Posts
nice...I know your not thinkin of this now and i even swore I would never do it.... but sprayin could be something to consider once you finish all the bolton mods possible... are you runnin an efan yet? do 4.7's benefit with a lower tstat?
 

·
Registered
Joined
·
13,690 Posts
Discussion Starter · #12 ·
Keep at it man, you may be able to get the the 13's without boost or spray. I'm amazed at how much faster your truck is than mine with nearly the same mods lol. I know it's not an even playing field but still, I ran a 16.1 friday...

I guess you just got a "good one" lol.
 

·
Registered
Joined
·
13,690 Posts
Discussion Starter · #13 ·
Fred, I don't believe he actually has that converter installed anymore, he had an issue with it where the clutch wouldn't lock. I think he is running the stock converter for now.
 

·
Registered
Joined
·
6,250 Posts
I hearya..funny thing is for me, i run the stock verter as well and have been running my pb's with it... I use to run a 2800 edge and it pulled like a mutha from the gitgo (my 60's were way better back then) but someone told me that our hemis liked the 'looseness' of the stock verter and my et's prove it...
 

·
Registered
Joined
·
13,690 Posts
Discussion Starter · #15 ·
^I don't know a lot about converters but I think the higher the stall rpm the less power you make at higher rpm's, so that makes sense...
 

·
Registered
Joined
·
507 Posts
Haha ok lets see If I can hit all your ?'s.
Yes I have considered going with a DRY system directed through the intake. Havent really pushed on the idea quite yet but very soon yes. Also I'm not sure how much the lower tstat will effect the performance but I am going to install one 180tstat this weekend regardless.
For the converter yes I did have trouble with the first aftermarket TC so I threw back in my stock one.
My 60 ft time was a 1.9. But I was at 32-34 psi with my radials and I was getting a little spin at the launch. So for sure when I go down to 20-25 psi they will grab better. I should be @ 1.6 1.7 60 ft time. At least that is what I'm shooting for. The 1/8 time I don't remember id have to look at ticket.

Next will be the tstat and underdrive pulley (thanks to my buddy snrusnak for he is going to try them on his truck before I install mine, he's been with me since my TC trouble back 3 or so months ago. Been great help)

:smileup:
 

·
Registered
Joined
·
13,690 Posts
Discussion Starter · #17 ·
Haha ok lets see If I can hit all your ?'s.
Yes I have considered going with a DRY system directed through the intake. Havent really pushed on the idea quite yet but very soon yes. Also I'm not sure how much the lower tstat will effect the performance but I am going to install one 180tstat this weekend regardless.
For the converter yes I did have trouble with the first aftermarket TC so I threw back in my stock one.
My 60 ft time was a 1.9. But I was at 32-34 psi with my radials and I was getting a little spin at the launch. So for sure when I go down to 20-25 psi they will grab better. I should be @ 1.6 1.7 60 ft time. At least that is what I'm shooting for. The 1/8 time I don't remember id have to look at ticket.

Next will be the tstat and underdrive pulley (thanks to my buddy snrusnak for he is going to try them on his truck before I install mine, he's been with me since my TC trouble back 3 or so months ago. Been great help)
Geeze my 60ft was 2.5 seconds lol.

The 180 tstat has been fine since I put it in and got the air out of the cooling system. The coolant temp hangs around 190. If your moving and it's cool out it'll stay around 188, maybe 186. If your sitting and it's hot out it'll keep climbing until the fan kicks on (I have mine set at 197), then slowly drops and hangs around 194 with the fan on. Then when you get moving again it goes back down around 190. We'll see how it does during summer heat, but I don't anticipate any issues.

I'm ordering the underdrive pulley today, gotta call the guy. In the upcoming weeks I'll let you know if it fits.

BTW, my goal was to get my truck to run a 14.99 or faster, and you did that without even really trying.....damn you...
 

·
Registered
Joined
·
507 Posts
Also yes I am running an Efan only. Took out the mechanical fan.
 

·
Registered
Joined
·
507 Posts
Geeze my 60ft was 2.5 seconds lol.

The 180 tstat has been fine since I put it in and got the air out of the cooling system. The coolant temp hangs around 190. If your moving and it's cool out it'll stay around 188, maybe 186. If your sitting and it's hot out it'll keep climbing until the fan kicks on (I have mine set at 197), then slowly drops and hangs around 194 with the fan on. Then when you get moving again it goes back down around 190. We'll see how it does during summer heat, but I don't anticipate any issues.

I'm ordering the underdrive pulley today, gotta call the guy. In the upcoming weeks I'll let you know if it fits.

BTW, my goal was to get my truck to run a 14.99 or faster, and you did that without even really trying.....damn you...
Ok cool, can't wait!
And I did try. Put a lot of effort into this! Haha blood sweat an tears. Way more blood though.
 
1 - 20 of 21 Posts
Top