DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello! I am having some real trouble with this one... I work at Napa and a co worker and I replaced my Bad U joints (which caused a terrible vibration) and went for a test drive. The ride was nice and smooth!! We heard a creaking noise coming from underneath. Jacked the rear up and put the her in neutral. When the drive shaft is spun by hand it sounds like the shaft is "creaking". Almost like the noise coming from a worn out mattress. I have never experienced this before. Could the U joints be causing some sort of binding issues? We are going to start all over again tomorrow but I was hopeing someone could share some advice. Thanks!!

-Finn

2010 1500 4x4
 

·
Registered
Joined
·
66 Posts
Hello! I am having some real trouble with this one... I work at Napa and a co worker and I replaced my Bad U joints (which caused a terrible vibration) and went for a test drive. The ride was nice and smooth!! We heard a creaking noise coming from underneath. Jacked the rear up and put the her in neutral. When the drive shaft is spun by hand it sounds like the shaft is "creaking". Almost like the noise coming from a worn out mattress. I have never experienced this before. Could the U joints be causing some sort of binding issues? We are going to start all over again tomorrow but I was hopeing someone could share some advice. Thanks!!

-Finn

2010 1500 4x4
sounds like one of the needle bearings in one of the cups might have slipped and is laying down in the cup instead of standing up right, it is not the first time this has happened and anyone who has replaced many u-joints have done the same time.
 
1 - 4 of 4 Posts
Top