DODGE RAM FORUM banner
1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
2010 4WD Crew Cab, 4.7, 8300 miles on the odometer. Girlfriend was driving on the highway today with the cruise control on, suddenly the cruise disengaged. She looked down and the cruise control light was off, and the following four idiot lights were illuminated: 1) ESP BAS 2) ABS (with circle logo) 3) SVC 4WD and 4) the sliding vehicle graphic. The truck is under warranty, but I live in BFE and the nearest dealer is two hours away, and I need the truck Monday, so thought I'd check here first and see if there might be a simple fix ...

Thoughts?

Thanks,

Steven
 

·
Registered
Joined
·
1,300 Posts
Last time I had an EBS and ABS light together and my cruise quit it was a speed sensor on my 05 dodge magnum. Not sure if you get the same with the Rams but I tend to think yes. Good luck but I would take it to be checked out if it were me, especially isnce it is a safety issue.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Thanks jacksonsnorth. Seems silly, the more sophisticated these warning systems are, the less capable they are of conveying useful information. Might as well just have one big red light that says "something's wrong with something." =)
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
So I had the local shop out here in BFE take a look, and it turns out there was a broken wire to the speed sensor at the left front wheel. (Good call, jacksonsnorth). Seems to change the sensor you have to change the entire hub. And since the wire was broken, a warranty repair was unlikely, so I had the local shop do it to the tune of $400. =(
 
1 - 7 of 7 Posts
Top