DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i have a 1983 dodge ram half ton and i recently bought it from a guy who had it running but it was very rough and he said it needed the carb cleaned, i cleaned the carb and checked to make sure all the plug wires were in order with the firing order of the truck and they are, the problem is the truck will start up for a few seconds and then die out, but it wont start up for the few seconds without me putting a bit of gas into the carb, but i know the fuel pump cant be bad because it drove when i got it, please help i want to drive this thing.
 

·
Premium Member
Joined
·
32,782 Posts
I think your fuel pump is mounted on the engine & not in the gas tank, but i may be wrong

If it is engine mounted, then they are the easiest to check
just pull off a line between the pump & the carburetor & have someone turn key, if it doesn't shoot gas about 3 feet, it could be the pump, but more likely it is the inline fuel filter.

It sounds like the pump is losing its PRIME

--------------------------------------------------------
I never liked dodge fuel pumps, only because they have an Inlet tube, an Outlet tube, & a third tube that returns fuel back to the gas tank, it is a crazy setup if you were to ask me
 

·
Registered
Joined
·
17 Posts
Mine did the same, but ended up the lobe on the cam was worn where the pump rides and not moving pump enough to make good psi. Try hooking a gas jug up run a line from jug to inlet on the pump then try. If it works then you have a problem with your fuel lines or in the tank. Hope helps
 
1 - 3 of 3 Posts
Top