DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter · #1 ·
Hello all, 2014 Ram 1500 with 5.7L 4x4 Laramie Longhorn package with about 58k. I have been noticing a slight chirping like squeal, almost like a belt thats slipping, when slowing to a stop or when turning at about 10-15 mph range. I can feel the engine down shift and thats when i hear the noise. It doesn't last long maybe a second or so and then its gone. Only hear it when slowing and feel the engine downshift and it only does it ususally after sitting overnight. It happens maybe two or three times and then once everything seems to warm up, I dont hear the noise anymore until the next day or so. Doesnt happen every day either, kind of random. I am hesitant to take it in for this because of how random it is and I am also no longer under warranty. Any thoughts or anyone with a same experience that may know whats going on? Thanks
 

·
Super Moderator
Joined
·
34,750 Posts
Mine was doing this a couple weeks ago when I'd come to a stop. It was always around 15 MPH which is when MDS disengages (it only works between 15-85 MPH), and only with the AC on. This was right at around 80,000 miles.


I replaced the serpentine belt and it hasn't happened since
 

·
Registered
Joined
·
171 Posts
Discussion Starter · #3 ·
Thanks, thats what i was hoping to hear. I checked the mopar online parts and found two belts. Part 4627897AB for $29.23 and 4627397AB for $44.54. The website says they both work but no description on what or why the difference is. Which part did you use or do you know the difference?
 

·
Super Moderator
Joined
·
34,750 Posts
I used an aftermarket one from Rockauto. It was around $20 and is supposed to be tougher
 
1 - 4 of 4 Posts
Top