DODGE RAM FORUM banner
1 - 13 of 13 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Tried to dyno my truck this weekend but ran into a few problems. First run was in 3rd gear with traction control off but smoked the rear brakes/traction control?? We had alot of smoke coming from passenger rear tire area and smelt like brakes burning. It only put down 183 on that run. Second run we put it in 4th gear and got 238 but same smoke and burning smell. What are we doing wrong and why wont my traction control completely disable? Wanting to run it again but dont want to be disappointed again. For the ones who have successfully dyno'd their trucks what did you do that I'm not? Thanks:4-dontknow:
 

·
Registered
Joined
·
698 Posts
From everything I've seen on this forum, just switching off the traction control button doesn't totally disable the traction control. Allegedly there is always some inherent TC...just not as aggessive. This sounds like what's happening here. There must be some slippage on the roller or something like it going on perhaps.
 

·
Registered
Joined
·
13,697 Posts
Like said above, you can't completely disable the traction control with the button on the dash, only partially.

I'd assume the sensors/pcm was freaking out because your rear wheels were moving and your front wheels weren't so it was trying to apply brakes to the rear to slow them down. I was going to suggest disconnecting the front wheels sensors but disabling the traction control via removing the ABS fuse sounds like a better and easier idea...
 

·
Registered
Joined
·
698 Posts
According the the NAV system, mine maxed out at 109, is that much variance normal?
Since it was your GPS giving that reading, it's probably fairly accurate. Since that governed speed isn't a legal mandate, it probably doesn't have to be exact. Also the speed might vary a bit because of drive gear ratios, tire size, and other subtle factors in the truck. It's a shame to some degree that Dodge does something like this.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #9 ·
thanks for all the suggestions..I go back in 2 weeks so Ill have him pull the fuse and see what we get..he is only charging me 50 bucks to dyno if everything goes good..didnt charge me anything this last time because we had so many problems..also forgot to mention that my torque converter didnt lock until 3100 rpm then unlocked at 3400..
 
1 - 13 of 13 Posts
Top