DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Im addicted to this forum. Im getting ready for inspection and im on the brake part of my truck now. When I have completed the truck I will make a build thread. Ive been taking pics along the way. The current issue is the ebake because Im waiting for brake lines in the mail. Now the ebake pedal locks but does not pull on the cable to engage the ebrakes. just goes right down. Im hopeing some one will have a link or a break down of the function of the pedal for me. So I can attempt to repair it rather than replace it. Thanks again guys.

Also on a side note Ive ordered some kenda klever mts 285/75/16s Any one tried them out? They look like they have good tread for the mud.
With the cheap price of $600 for all four I couldnt resist replaceing the studded snows.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #2 ·
NM im missiong the coil that pulls the ebrake when it gets tension from the pedal. How about them tires though? sure beats paying $950 for bfgs
 

·
Registered
Joined
·
74 Posts
Seems like a sweet deal for the tires.

are your rear brakes adjusted? if the rears get way out of adjustment, then the parking break will go to the floor before engaging.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #4 ·
The coil that winds up and pulls the cable is missing. I noticed I could pull on the cable by hand but the pedal didnt pull it. I was hopeing a tab had worn down that catches the cable side. However its actaully a tension coil. I noticed it in pics when I was looking at them on ebay.
 
1 - 4 of 4 Posts
Top