1 - 2 of 2 Posts

· Registered
3 Posts
Discussion Starter · #1 · (Edited)
Problem solved Electric cooling assist fan problem - no power to circuit

Problem solved, disregard.:smiley_thumbs_up:

Hi all,

2010 1500 TRX4 with 4.7, 175,000 miles. Had to replace the radiator and also found the electric cooling fan connected to the radiator was not working. Found a bad place in the wire where it went into the fan motor. Replaced it with new motor/assembly.

There is no electrical signal coming to the relays to make the fan come on. My brother and I (he is the mechanic, not me) checked:

- new fan works with jumper wire (with inline fuse of course)
- fuse and relays are good (checked with power and ohm meter per instructions in the Chilton manual.) It has two relays - one for overheat protection, the other when AC is turned on - neither is getting a signal.
- Circuit from the fuse box to the fan is good.
- No loose connections that we could find under the hood

I realize this could be a ECM problem, but is there a sensor somewhere that could be bad?

I'd appreciate any ideas.
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.