DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
First, my truck began idling real low around 300-250 rpm along with low oil pressure light. Now it won't even stay running unless I keep my foot on the gas! When I press on the gas pedal the oil pressure goes back to normal range and oil pressure light goes away. However, as soon as I let off the gas it drops to zero and dies.


I thought it was the fuel pump, so I went ahead and replaced that. Replaced air filter. I believe i'm getting good fuel pressure from the pump because I put the fuel line in a plastic bottle, cranked the engine over and a generous amount of fuel poured into the bottle. Also, I tried cleaning my fuel injectors and still the same problem. When I rebuilt the motor (about 400 miles ago) I had replaced the Idle Air Control Valve on the throttle body.

I'm starting to think either 1) my timing went screwey, 2) I bought a cheapo Idle Air Control Valve that got stuck, 3) I need to check the throttle position sensor.



Any comments, questions, or concerns will help. Thanks ya'll!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
UPDATE: put in the IAC sensor that came stock on the truck, it was still good even though I replaced it with the chinese one last November. My truck starts everytime and runs smoothly... Even feel a little more power from when I cleaned the fuel injectors.

MORAL OF THE STORY: don't but cheapo Chinese sensors. Get a good mopar one. The Chinese one lasted only about 400 miles! Spend more on quality
 
1 - 3 of 3 Posts
Top