DODGE RAM FORUM banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Just bought a '97 Ram 2500 4x4 with 122k on it. Just had a few questions, though. One is, the coolant temp on the dash seems to fluctuate between 180-200F when driving the truck. Is this normal? If I am at a stop for a while it goes up to just about the middle mark (200) and then when I start moving it almost immediately goes back down to about 180 or so. I also noticed the coolant reseviour tank is empty. But I see no noticeable leaks anywhere.

Second is the 4WD light on the dash seems to flicker on and off. I tested the 4WD when I bought the truck and it worked fine and seemed to shift between 2WD and 4WD fine, it's just the dash light likes to flicker here and there. Is this just possibly a switch or sensor needing adjustment?

Thanks in advance for your help. So far, I really like this truck.
 

·
Registered
Joined
·
462 Posts
Both of my trucks are pretty 'coolant level sensitive', and if low at ALL, they send cold air out of the heat ducts, and the gauge wanders. This is even if they're only a cup or so low in the radiator. If the radiator is low, the expansion tank is probably going to drink up a half gallon. Now the 4x4 light. Hmm, thats a new one for me, never heard of an intermittant lite... I'd probably go to the axle disconnect, and pull the plug and look at the pins, etc to see if they're corroded, for starters... My 95s light for 4x4 has never worked, (only recently discovered that it has one!!) I know the 96 has the same light, I don't know about the 97s, my 98 is all different on the instrument cluster, and it's always worked great, except when one of the vacuums tube fell off, on the left side of the crossmember, and the light didn't work, but neither did the axle disconnect. (so it isn't the vacuum tube disconnected on yours)
 
1 - 2 of 2 Posts
Top